IMAP polls showing previously deleted messages as new

RESOLVED DUPLICATE of bug 229003

Status

RESOLVED DUPLICATE of bug 229003
15 years ago
10 years ago

People

(Reporter: ez-be0x, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113 MultiZilla/1.6.0.0e
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

I use an procmail on our Linux server to distribute incoming mail to various
IMAP folders.

Often, I just examine the headers of new mail and delete those messages without
viewing them or marking them as read.

Using Mozilla 1.5, each time my IMAP folders were checked, the folder message
counts appeared "normal", that is, only real new mail showed in the unread count
and only undeleted messages showed in the total count.

After upgrading to Mozilla 1.6, polling IMAP folders where previously deleted
unread messages will those those delete messages as new messages. Clicking on
the individual folders then clears the counts and show no new messages.
Compacting the folders corrects the problem.

I noticed that Mozilla 1.5 would issue a "select {folder}" each time it polled
for new messages. My server would return something like "0 EXISTS" and "0
RECENT" for folders where I had deleted all unread/unviewed messages.

Now, Mozilla 1.6 uses something like "STATUS {folder} (UIDNEXT MESSAGES UNSEEN
RECENT)". Since I deleted unread messages, my server responds with something
like: "STATUS {folder} (MESSAGES 1 RECENT 0 UNSEEN 1 UIDNEXT 1563)". This I
believe causes Mozilla to show new messages, even though they were previously
deleted. Clicking on the folder then clears the counts and shows no new
messages, until the next poll.



Reproducible: Always

Steps to Reproduce:
1. Send a message to myself which procmail will redirect to a separate folder.
2. Launch Mozilla and do "Get Msgs" to poll all IMAP folders.
3. Select folder with new message. Delete that message without viewing or
   marking as read.
4. Exit or wait for next poll interval.

Actual Results:  
Folder count shows deleted message(s) as new.

Expected Results:  
Show only unread/undeleted message count.
(Reporter)

Updated

15 years ago
Summary: IMAP polls showing previously deleted messages and new → IMAP polls showing previously deleted messages as new
(Assignee)

Comment 1

15 years ago
this is fixed in new trunk builds - deleting a message marks it as seen. Dup of
several bugs - I'll pick bug 229003

*** This bug has been marked as a duplicate of 229003 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.