If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hitting back in the browser does not scroll page to last viewed position.

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Kevin Ar18, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040115 Firebird/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040115 Firebird/0.8.0+

In the URL mentioned, if you scroll down the page, and then click on a link at
the bottom and let the new page load, and then hit back, then the page does not
scroll to the same position you were at before.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.msnbc.msn.com/Default.aspx?id=3855168&p1=0
2. Scroll to the bottom of the page, and click on a link
3. Let the page load.
4. Go back (For example, hit the backspace key.)

Actual Results:  
The previous page is loaded, but the scroll position is at the very top.

Expected Results:  
The previous page should load with the scroll position at the bottom of the page
where you left it.

Updated

14 years ago
Assignee: blake → nobody
Component: General → Layout
Product: Firebird → Browser
QA Contact: core.layout
Version: unspecified → Trunk
This needs a minimal testcase.... (for one thing, I can't reproduce this locally
when I save the page, complete, so it may be something about this site's HTTP
headers that's the problem...).

Comment 2

14 years ago
Is this related to 217120 ?

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 217120 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

14 years ago
Could this be Bug 215405? Uses this site such cache controls?
(Reporter)

Comment 5

14 years ago
Perhaps I could do a testcase on it to see.  It might be a little while before I
can do so, however.

Comment 6

14 years ago
works for me in a mozilla 1.7 trunk build from yesterday.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

14 years ago
I can't reproduce this bug anymore either (new or old build).
Thank you for testing it again for me (and marking it as WORKSFORME).
You need to log in before you can comment on or make changes to this bug.