If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SVG-enabled Mozilla builds do not render svg files even with ADOBE's SVG plugin installed

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Sachin Bansal, Unassigned)

Tracking

({testcase})

Trunk
Other
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla 1.5a (SVG-enabled build)


SVG enabled Mozilla builds do not render svg files even with Adobe's SVG 
plugin. Non-SVG enabled (SVG disabled) Mozilla builds render SVG files 
correctly without any problems.
If SVG is embedded inside html document (through "EMBED" tag), it gets 
rendered, but if <SVG> is the root tag, mozilla is not able to render it. When 
trying to render an SVG file, Mozilla pops up the alert box which prints the 
message: 
"The file is of type image/svg+xml (Scalable Vector Graphics) and mozilla does 
not know how to handle this file."


Expected: 
SVG enabled Mozilla should be able to render SVG files properly. If ADOBE's 
SVGViewer plugin is installed, Mozilla should let user decide if user wants to 
use (Mozilla's inbuilt SVGViewer or ADOBE's SVGViewer plugin, or from 3rd 
party), atleast until Mozilla implements significant portion of SVG spec. 
itself.

Reproducible: Always

Steps to Reproduce:
1. Download Mozilla 1.5a (SVG enabled build)
2. Try opening any svg file, it opens up the dialog box about not able to open 
SVG files
3. Installed Adobe's Linux version of SVGViewer from 
http://www.adobe.com/svg/viewer/install/main.html
4. Try to open the same file again, it will still show the problem opening the 
file.

Actual Results:  
SVG enabled Mozilla builds do not render svg files even with Adobe's SVG 
plugin. Non-SVG enabled (SVG disabled) Mozilla builds render SVG files 
correctly without any problems.
If SVG is embedded inside html document (through "EMBED" tag), it gets 
rendered, but if <SVG> is the root tag, mozilla is not able to render it. When 
trying to render an SVG file, Mozilla pops up the alert box which prints the 
message: 
"The file is of type image/svg+xml (Scalable Vector Graphics) and mozilla does 
not know how to handle this file."

The same problem persists with Mozilla 1.6 build (svg enabled, which I 
compiled myself).


Expected Results:  
SVG enabled Mozilla should be able to render SVG files properly. If ADOBE's 
SVGViewer plugin is installed, Mozilla should let user decide if user wants to 
use (Mozilla's inbuilt SVGViewer or ADOBE's SVGViewer plugin, or from 3rd 
party), atleast until Mozilla implements significant portion of SVG spec. 
itself.

I am using Dell GT270 with Red Hat linux 9e installed in one of the partitions.
The same problem persists with Mozilla 1.6 build (svg enabled, which I 
compiled myself).
.
Component: Browser-General → SVG

Comment 2

14 years ago
Created attachment 141262 [details]
simple SVG testcase

If I understand correctly, then SVG files like this one could not be rendered.
I don't have a Linux machine around right now, but WFM with build 2004020709 on
Win2K. Reporter, please try this testcase with an older and with a recent
build.

Updated

14 years ago
Keywords: testcase

Comment 3

14 years ago
Since the landing of the SVG development branch (bug#182533), svg-enabled builds
will now correctly recognise the 'image/svg+xml' mime type and show svg files
using the native svg capabilities, so I'm marking this bug as fixed.

Being able to switch between plugin and native svg support is a different issue.
If you feel this should be possible (I'm not sure it should), then please file
an 'enhancement' bug on it where we can discuss it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Summary: SVG-enabled Mozilla builds do to render svg files even with ADOBE's SVG plugin installed → SVG-enabled Mozilla builds do not render svg files even with ADOBE's SVG plugin installed
You need to log in before you can comment on or make changes to this bug.