Copying sent mail into "Sent Mail" folder not interrupted when "Cancel" is hit

RESOLVED DUPLICATE of bug 206408

Status

RESOLVED DUPLICATE of bug 206408
15 years ago
10 years ago

People

(Reporter: doron, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Using IMAP, windows client.
Sending a large mail, I wish this mail (only) not to be copied
to the Sent Items folder. After the mail is being sent successfully, 
the message "Copying to Sent Items folder" is displayed with a "Cancel"
button. I hit the button, the message window closes down, but the 
copying moves on (very large mail, over IMAP, takes a few minutes).
Then, I get the "copy failed" message window, *however* the mail 
was fully copied to the Sent Items folder (i.e. operation was not
interrupted by pressing "Cancel").

I believe this is new to 1.6 (at least it used to work in a past ver -
not sure I tested it at 1.5).

Corollary: need an option to specify, for a particular mail, 
that I don't want it copied to the Sent Items folder.
Probably deserves a new bug.

Reproducible: Always

Steps to Reproduce:
1. Send a large mail using IMAP.
2. When message window "Copying to Sent Items folder" shows, press "Cancel".
3.

Actual Results:  
Message window closed, but copying continued for a long time (10 minutes).

Expected Results:  
Interrupt the copying (cleanly) and ask whether to retry it.
(Assignee)

Comment 1

15 years ago
this is fixed on the 1.7 trunk, but not in 1.6. I believe this is a dup of
206409. Can you try a 1.7 trunk build?

I don't believe this ever worked in Mozilla - it may have looked like it worked,
but cancel didn't really do anything except get rid of the progress dialog.
(Reporter)

Comment 2

15 years ago
Thanks - you sure you got the number right? I fail to see how Bug 206409 
is relevant here - what am I missing?

Can't test 1.7 right now unfortunately.
(Assignee)

Comment 3

15 years ago
d'oh, bug 206408 - marking as dup. But if you can try 1.7 at some point, please
let me know. 1.7 also will give you percent progress during the fcc, if you need
any more incentive :-)

*** This bug has been marked as a duplicate of 206408 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.