Apostrophes on some web site show up as squares.

RESOLVED DUPLICATE of bug 226758

Status

()

Core
Internationalization
--
major
RESOLVED DUPLICATE of bug 226758
14 years ago
14 years ago

People

(Reporter: cool_otter, Assigned: smontagu)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040123 Firebird/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040123 Firebird/0.8.0+

On some web pages, Mozilla Firebird displays apostrophes(') as small squares
where the apostrophe should have been. The trouble is, on some web sites the
apostrophes show up perfectly normally, while on others they show up as...
squares! I never had this problem before with Mozilla Firebird, I think it may
be a problem with the fonts. 

Reproducible: Always

Steps to Reproduce:
1.I have a fresh Mandrake 9.2 Install- Installed Windows fonts also as well as
XFree86-75dpi-fonts package and also some Chinese fonts and Bitstream Vera fonts.
2.Go to http://www.mozilla.org/get-involved.html
3.Read the paragraph starting with "So you want to help?"

Actual Results:  
I saw 

"You don<BOX>t have to be a C++ guru and you don<BOX>t need to spend lots of time"

(Imagine a small square instead of <BOX>)

Expected Results:  
I should have seen

"You don’t have to be a C++ guru and you don’t need to spend lots of time"

(With no boxes at all!) 

I am using the GTK (latest nightly) build of Mozilla Firebird. The apostrophes
render correctly in Konqueror and Galeon.
(Reporter)

Comment 1

14 years ago
I just tried opening the same page in Mozilla (SeaMonkey, NOT Mozilla Firebird),
and the apostrophes are also normal! 
Summary: Apostrophes on some web site show up as squares. → Apostrophes on some web site show up as squares.

Comment 2

14 years ago
This WFM on both:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040124
Firebird/0.8.0+
and
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040124 Firebird/0.8.0+
(using Fedora Core 1, GTK2/Xft)
(Reporter)

Comment 3

14 years ago
The apostrophes show up fine for me in the XFT and GTK2 build, but they don't in
the GTK build. 

Comment 4

14 years ago
The problem seems to be with the apostrophe character used (&#8217;) in the
encoding used by the page (ISO-8859-1). This character is also called "right
single quotation mark" or &rsquo; (source:
http://www.htmlhelp.com/reference/html40/entities/special.html)

Support is supposed to be limited, but it WFM on Win2k with:
IE 5.5
IE 6
Lynx on cygwin
Opera 6

Comment 5

14 years ago
With moz 1.6 on linux (rh7.2/up2date'd) seems like I seen a _lot_ more "squares"
than with 1.4 from which I recently upgraded. It has gotten about as bad again
as it was with n/s 4.x when m/s "smart quotes" caused similar effect. I am
writing this on win2k now and don't see problems with moz 1.6.

Comment 6

14 years ago
I started seeing this (boxes instead of apostrophes) when I installed Mozilla
1.7b on Red Hat Linux a few weeks ago.  I am all but certain it was not
happening before when I was running Mozilla 1.4rc1.

I also run Mozilla 1.7b on Mac OS 10.3.3 and the "apostrophes" display normally,
but indeed as Comment #4 says, these are not vertical single quotes, but "right
single quotation mark" (shaped like a "/" or a ",").

Note that as in Comment #5 this is a problem in Mozilla whereas this bug is
filed against Product Firefox.  I'm hoping that means Product should be changed
(to "Browser"?) and not that I'm commenting on the wrong bug.

Comment 7

14 years ago
Confirm comment #3:

I also encountered this problem in Linux Mozilla 1.7 RC2 GTK1 build.

Hopefully it will be fixed before the 1.7 final is released.

Comment 8

14 years ago
Confirmed with Mozilla 1.7 RC2 on RH 7.3. Product should be changed to Browser.
This broke between 2003-07-07-05 and 2003-07-09-22, looks like.  Checkins:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2003-07-07+05%3A00%3A00&maxdate=2003-07-09+22%3A00%3A00&cvsroot=%2Fcvsroot

smontagu, looks like your checkin for bug 199143 broke this, perhaps?  We used
to fallback to a normal quote for these chars, and we don't anymore...
Assignee: firefox → smontagu
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: General → Internationalization
Ever confirmed: true
Product: Firefox → Browser
QA Contact: amyy
Version: unspecified → Trunk
(Assignee)

Comment 10

14 years ago
Boris, you're right: see bug 226758 comment 6.

*** This bug has been marked as a duplicate of 226758 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.