Closed Bug 232134 Opened 16 years ago Closed 16 years ago

Multiple "server unavailable" modal error boxes pop up while checking mail if IMAP server is unavailable

Categories

(Thunderbird :: Mail Window Front End, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 123440

People

(Reporter: bugzilla.spam, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

If a mail server goes down or is for some reason unavailable, Thunderbird pops
up multiple modal error dialog boxes, one for every time it unsuccessfully tried
to connect. If it's left like this for a long time, hundreds of error dialogs
pop up, and you must click "OK" on every one before you regain control of
Thunderbird. There should be only one.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird, making sure you have multiple IMAP accounts set up.
2. Set it to check mail every minute or something similar.
3. Prevent it from connecting-- block it at the firewall, add a 127.0.0.1 entry
to your hosts file, physically pull out your Internet connection, turn the
actual mail server off for a moment
3. Watch as it begins to throw multiple error messages. You must click on EVERY
one before you regain control of the program.

Actual Results:  
The bug described above was reproduced. I either have to click on every single
dialog box or force quit the program.

Expected Results:  
Put up ONE dialog box even if Thunderbird couldn't connect hundreds of times.
I've experience this too, I agree with the "Expect Results".
I have this problem too.  I have a very unreliable connection to a very
unreliable mail server, so every morning I have to click through 20 or more
identical dialogs before I can read my mail.  When you combine this with bug
195596 it gets even worse.  The mail isn't apparently being checked, yet I get
tens of error messages.

I think a better solution would be to not use a dialog at all.  Since there is
only one option for the dialog (OK) it should be replaced with a warning *in the
mail frame*, perhaps in the status bar, or some other area.  This way the dialog
popping up wouldn't haul me across virtual desktops and grab the focus from my
current application.  I realize this is probably a KDE issue, but
Mozilla/Thunderbird doesn't help matters.

PS: this is on Linux so I guess the OS is probably 'ALL', but I don't know if
I'm supposed to be changing that, so I'll leave it.
This happens also on linux, w/ thunderbird 0.5. 

*** This bug has been marked as a duplicate of 123440 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.