Obsolete attachments no longer struck through

RESOLVED WORKSFORME

Status

()

Bugzilla
Attachments & Requests
--
trivial
RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: Waldo, Assigned: myk)

Tracking

Details

(URL)

See bug 217410.  All attachments except the last one are obsolete.  To confirm,
simply click on Edit.  Each is marked as Obsolete, but none are struck through
to show this simply.  This problem isn't on landfill.

I want this to have a different severity (preferably major), but it is a
cosmetic problem and a workaround is present.
I can't reproduce.  Every attachment on that bug DOES have a strikethrough on
the description, except the last one.  You sure it's not your browser?  (what
browser are you using, btw?)
It appears to be caching issues with Mozilla Firebird (20030114 Win32 0.8 branch
build), as page refreshes did nothing.  D'oh!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

14 years ago
I'm not so sure this is a simple WORKSFORME.  There have been numerous reports
of intermittent failure for obsolete attachments to be struck through since the
upgrade.  In all cases except for this one, reloading the page solved the
problem.  I haven't been able to reproduce the problem myself, but enough people
have reported it for me to think it's real.

Reopening until we get a better sense of what's going on here.  If no new
information pointing to Bugzilla shows up within a few days, feel free to close
again.  And Jeff, if you discover that it really is your browser, feel free to
move this bug to the Firebird product with a description of how to reproduce in
that browser.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This is caused by browser caching.  The way we did strikethrough styling for
attachments in the past was to use <strike> elements.  In bug 153583, I changed
that to use css, applied via a class attribute, and added the appropriate class
selector to edit_bug.css.  If before you reload, you look at
http://bugzilla.mozilla.org/css/edit_bug.css you will see an old version of the
stylesheet.  Refreshing pulls in the new style sheet, and thus the styles can
then be applied by the browser.

Comment 5

14 years ago
After forced reload to update cache, 

WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040120
Firebird/0.7+

We seem to have a sane explanation which fits the facts here.

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.