sometimes, Mozilla stalls in dns lookup

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Hervé Renault, Assigned: gordon)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
sometimes, it stalls in dns resolving unless i open a new window and then it
goes at full speed again. i cannot find a related bug in bugzilla.

alecf told
me "hrm. . . I've seen that on previous builds but not in m13 thus far".

i use
the latest cvs sources / Linux SuSE 6.2.

i stopped when it stalled, and here's
a backtrace :

(gdb) bt
#0  0x403b1d4d in __poll (fds=0xbf5fe6c0, nfds=1,
timeout=5000)
    at
../sysdeps/unix/sysv/linux/poll.c:45
#1  0x40294ca7 in
__res_send
(buf=0xbf5fe908 "Ë%\001", buflen=33,
    ans=0xbf5ff5a4
"Ë$\201\200ÐFi@",
anssiz=1024) at res_send.c:626
#2  0x40293cb5 in res_query
(name=0x8c3f120
"www.mmedium.com", class=1,
    type=1, answer=0xbf5ff5a4
"Ë$\201\200ÐFi@",
anslen=1024) at res_query.c:134
#3  0x40294111 in
res_querydomain
(name=0x8c3f120 "www.mmedium.com",
    domain=0x0, class=1,
type=1,
answer=0xbf5ff5a4 "Ë$\201\200ÐFi@",
    anslen=1024) at res_query.c:352
#4
0x40293e9a in res_search (name=0x8c3f120 "www.mmedium.com", class=1,

type=1,
answer=0xbf5ff5a4 "Ë$\201\200ÐFi@", anslen=1024) at res_query.c:216
#5
0x417b8d9c in _nss_dns_gethostbyname2_r (name=0x8c3f120 "www.mmedium.com",

af=2, result=0x403fac04, buffer=0x82f5690 ">¡Q\235cX/\b", buflen=1024,

errnop=0xbf5ffec0, h_errnop=0xbf5ffa98) at nss_dns/dns-host.c:166
#6  0x417b8e71
in _nss_dns_gethostbyname_r (name=0x8c3f120 "www.mmedium.com",

result=0x403fac04, buffer=0x82f5690 ">¡Q\235cX/\b", buflen=1024,

errnop=0xbf5ffec0, h_errnop=0xbf5ffa98) at nss_dns/dns-host.c:190
#7  0x403cc9f8
in __gethostbyname_r (name=0x8c3f120 "www.mmedium.com",
    resbuf=0x403fac04,
buffer=0x82f5690 ">¡Q\235cX/\b", buflen=1024,
    result=0xbf5ffa94,
h_errnop=0xbf5ffa98) at ../nss/getXXbyYY_r.c:182
#8  0x403cb7c3 in gethostbyname
(name=0x8c3f120 "www.mmedium.com")
    at ../nss/getXXbyYY.c:136
#9  0x4022da81
in PR_GetHostByName (name=0x8c3f120 "www.mmedium.com",
    buf=0x41807674
"¨\005", bufsize=1024, hp=0x41807658) at prnetdb.c:378
#10 0x40688799 in
nsDNSService::Lookup (this=0x8431c50, clientContext=0x0,
    hostName=0x8c3f120
"www.mmedium.com", listener=0x8c3f004,
    DNSRequest=0x8c3f01c) at
nsDnsService.cpp:618
#11 0x40672cbb in nsSocketTransport::doResolveHost
(this=0x8c3f000)
    at nsSocketTransport.cpp:618
#12 0x40672729 in
nsSocketTransport::Process (this=0x8c3f000, aSelectFlags=0)
    at
nsSocketTransport.cpp:494
#13 0x40676784 in
nsSocketTransportService::ProcessWorkQ (this=0x8431ec8)
    at
nsSocketTransportService.cpp:247
#14 0x40676f5d in nsSocketTransportService::Run
(this=0x8431ec8)
    at nsSocketTransportService.cpp:481
#15 0x40190575 in
nsThread::Main (arg=0x8465870) at nsThread.cpp:83
#16
0x4024331b in _pt_root
(arg=0x85728d0) at ptthread.c:157
#17 0x4026518a in
pthread_start_thread
(arg=0xbf5ffe78) at manager.c:214
(gdb)

no other application (including Nav4.x)
does exhibit this behaviour on the same
machine at the same time.
(Reporter)

Comment 1

18 years ago
i must add that, sometimes i get this type of backtrace when i stop while it's
"stalled":

(gdb) thr 4
[Switching to thread 4 (Thread 17108)]
#0  0x403b1d4d in __poll (fds=0xbf5ffc80,
nfds=2, timeout=24245)
    at ../sysdeps/unix/sysv/linux/poll.c:45
45      in
../sysdeps/unix/sysv/linux/poll.c
(gdb) bt
#0  0x403b1d4d in __poll
(fds=0xbf5ffc80, nfds=2, timeout=24245)
    at
../sysdeps/unix/sysv/linux/poll.c:45
#1  0x402412fb in PR_Poll (pds=0x831add8,
npds=2, timeout=35000) at ptio.c:3581
#2  0x40676e01 in
nsSocketTransportService::Run (this=0x8431ec8)
    at
nsSocketTransportService.cpp:424
#3  0x40190575 in nsThread::Main
(arg=0x8465870) at nsThread.cpp:83
#4  0x4024331b in _pt_root (arg=0x85728d0) at
ptthread.c:157
#5  0x4026518a in pthread_start_thread (arg=0xbf5ffe78) at
manager.c:214
(gdb)

i'm sorry i've no time to diagnose what happens...

Updated

18 years ago
Assignee: gagan → gordon
Target Milestone: M13

Comment 2

18 years ago
-> gordon
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M15
(Assignee)

Comment 3

18 years ago
I haven't been able to reproduce this.  Do you still see this?  I'm working on
the cache for M14, so I'm moving this bug to M15.

Comment 4

18 years ago
Yes, i still see this. Important: It happens from time to time. It's hard to
reproduce, indeed.
Maybe it could be related to our DNS server, but only mozilla is hit by this
problem. Nav4.x is not. And when it occurs, i stop, i open a new window and it
works fine again, the page loads in a eye blink.

I'm using a fresh cvs pullout from monday 2000-01-17.
(Reporter)

Comment 5

18 years ago
I've not seen this phenomenon with the binary M13, since it's been out.

Maybe that problem was due to the fact that i ran in gdb before M13 ?

(i used to compile Moz on my SuSE 6.2 box, before M13)

If no one has been hit by this one, you can close the bug.



(Assignee)

Updated

18 years ago
Target Milestone: M15 → M17

Comment 6

18 years ago
Moving post beta bugs to M18 which is now the post-beta milestone.
Target Milestone: M17 → M18
(Reporter)

Comment 7

18 years ago
this does not happen anymore, can you close the bug ?
(Assignee)

Comment 8

18 years ago
Closing.  Please reopen if you see this problem again.  Thanks.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 9

17 years ago
verified WFM
You need to log in before you can comment on or make changes to this bug.