CC: in new bug causes Software Error on post_bug.cgi, bug entered but no email sent

RESOLVED DUPLICATE of bug 177828

Status

()

Bugzilla
Creating/Changing Bugs
--
major
RESOLVED DUPLICATE of bug 177828
14 years ago
5 years ago

People

(Reporter: Keith Tyler, Assigned: myk)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: 

When creating a new bug in Bugzilla, if a CC: is entered, the commit creates 
the bug in the DB, but no mail is sent, and you are taken to post_bug.cgi with 
text like the following:

==========8<==============
Content-type: text/html 
Software error:
SELECT profiles.userid, profiles.groupset, profiles.login_name, 
profiles.login_name = 'keith.tyler@cyphermetrix.com' AND logincookies.ipaddr 
= '192.168.32.110', profiles.disabledtext  FROM profiles, logincookies WHERE 
logincookies.cookie = '61' AND profiles.userid = logincookies.userid:  at 
globals.pl line 276.
For help, please send mail to the webmaster (bugzilla@cyphermetrix.com), 
giving this error message and the time and date of the error. 
==========8<==============

The email address that appears in the query is that of the person submitting 
the bug.

The page then ends at that point.

Server info:
Bugzilla 2.16.3
Linux 2.4.20-20.9 #1 Mon Aug 18 11:45:58 EDT 2003 i686 i686 i386 GNU/Linux
MySQL version 3.23.56

Reproducible: Always
Steps to Reproduce:
1. Go to add new bug.
2. Enter bug as normal.
3. Be sure to add a user to the CC: field.
4. Press confirm.
Actual Results:  
See details

Expected Results:  
Saved the bug, sent email, and displayed the newly created bug in the rest of 
the page.
Why are you using 2.16.3? Have you had this Bugzilla for a while, and only just
noticed the problem?

Gerv
This is already fixed, btw.  you need to upgrade.

*** This bug has been marked as a duplicate of 177828 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
About three months or so. Noticed the problem transiently but hadn't tried to 
replicate.

I did not see this issue addressed in the 2.16.4 changelog.

Will push for an upgrade. Thanks.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.