Backgrounds Configured Optional

RESOLVED WONTFIX

Status

SeaMonkey
Preferences
--
enhancement
RESOLVED WONTFIX
14 years ago
13 years ago

People

(Reporter: lucianolll, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

BACKGROUNDS Optional in this page ViewSource ; configured in Preferences ;
Suggestion ; BACKGROUND optional for page ViewSource;
Automatic configured ; Preferences ; BACKGROUND Optional;
WYCIWYG - ViewSource: <body style="++ BACKGROUNDS Optional in Preferences
++"></body>
My Suggestions for Improvement; Mozilla Visualizations Backgrounds ;

Reproducible: Always
Steps to Reproduce:
BACKGROUNDS Optional in this page ViewSource ; configured in Preferences ;
Suggestion ; BACKGROUND optional for page ViewSource;
Automatic configured ; Preferences ; BACKGROUND Optional;
WYCIWYG - ViewSource: <body style="++ BACKGROUNDS Optional in Preferences
++"></body>
My Suggestions for Improvement; Mozilla Visualizations Backgrounds ;
Actual Results:  
  

Backgroud #FFFFFF ; This is NOCIVE BACKGROUD ;

Expected Results:  
BACKGROUNDS Optional in this page ViewSource ; configured in Preferences ;
Suggestion ; BACKGROUND optional for page ViewSource;
Automatic configured ; Preferences ; BACKGROUND Optional;
WYCIWYG - ViewSource: <body style="++ BACKGROUNDS Optional in Preferences
++"></body>
My Suggestions for Improvement; Mozilla Visualizations Backgrounds ;


For Commodity Navegations ; Visibility ; Natural Colors ;
Page 'View Source'  ; 

BACKGROUNDS Optional in this page ViewSource ; configured in Preferences ;
Suggestion ; BACKGROUND optional for page ViewSource;
Automatic configured ; Preferences ; BACKGROUND Optional;
WYCIWYG - ViewSource: <body style="++ BACKGROUNDS Optional in Preferences
++"></body>
My Suggestions for Improvement; Mozilla Visualizations Backgrounds ;
(Reporter)

Comment 1

14 years ago
  In this page - View Source -    
Backgroud #FFFFFF ; This is NOCIVE BACKGROUD 
 Example visualization page
 Suggestion -- View Page Source - Improvement
   ---------------------------------------------------
   | Source of: http://bugzilla.org/                 |
   ---------------------------------------------------
   |
   |   This BACKGROUND configured in options         |
   |   Preferences ; Apearance ; Colors ;            |
   |   Background -- ViewSource -- | #color1 |       |
   |   #color1 is ; optional personal backgrounds    |
   ---------------------------------------------------


 Background #FFFFFF is NOCIVE;
  Preferences ; Appearance ; Colors ;
   Examples - Invitation -
 Click ---  | Luciano lll POP | in my page
  http://www.lucianolll.pop.com.br/
  this NATURAL colors view
#EEDDCC 238 221 204
#E6E9D0 230 233 208
#E9E6D0 233 230 208
#FDF0E0 253 240 224
#FFF3DE 255 243 222
#FFEEDD 255 238 221
#FFF0E0 255 240 224
#FFE9D9 255 233 217
#FFFAEA 255 250 234
#FAE4CC 250 228 204

Congratulations
I don't understand this bug, but in any case it does not appear to be security
sensitive, so I am making this public. This also looks like this is an
enhancement request rather than a bug in the product, so changing severity.
Group: security
Severity: critical → enhancement
*** Bug 232263 has been marked as a duplicate of this bug. ***
*** Bug 232261 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
Are you trying to say the viewsource background color should be configured by
the user and can be diffrent from the default background color for websites?
If this is true we should also set an option for the foreground.

Bug 141251 is simular but thinks backgrounds should be the same.
Bug 62678 is the one that changed viewsource to use black on white

Comment 6

14 years ago
*** Bug 232265 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

14 years ago
Translation
With satisfaction and admiration


Em língua nativa; Português

Tenho presenciado dois bugs durante a navegação que considero de seria importância;
Um bug; Quando sou forçado a visualizar página no Navegador Mozilla que
configuradas em fundo #FFFFFF ; branco que nocivo aos olhos durante longas leituras;
Minha sugestão é de se implantar no navegador uma opção fácil; por exemplo com o
botão esquerdo do mouse para escolher o fundo; BACKGROUND OPCIONAL ; da pagina;
A cor BRANCA #FFFFFF ; é nociva aos olhos para longas leituras;
--------------------
Isto aparece durante a visualização de páginas no Navegador; e também;
Isto aparece quando quero verificar o código fonte da página; quando escolho
"VIEW PAGE SOURCE" ; A página gerada no VIEW SOURCE é com FUNDO BRANCO #FFFFFF ;
Que é nocivo; pelo excesso de brilho da luz; Esta página deve ter o FUNDO de cor
configurado pelo USUÁRIO e não como uma pagina de fundo padrão branco #FFFFFF
apenas;
--------------------

Tanto para o Navegador; quanto para a opção "VIEW SOURCE" do Navegador;
O usuário deve ter a opção de configurar por si mesmo o fundo da pagina de
navegação;
Cores agradáveis podem ser escolhidas pelo usuário; como por exemplo;
#EEDDBB ;#FEEECC ;#FDF0E0 ;#FFF3DE ;#FFEEDD ;#FFF0E0 ;#FFE9D9 ;#FEF0E0 
#FEF7E7 ;#FFFAEA ;
FICANDO COMO PERMANENTES até que o usuário queira outras ou a padrão;

Pode-se criar no Navegador uma opção como "Page Configurations" ; Isso tanto
para o visualização das paginas no navegador quanto da operação de ver o código
fonte ; ou VIEW PAGE SOURCE ;

Isso em Editar Preferências ou diretamente no Mouse ; com o botão esquerdo ;

----------------
Assim o Navegador ficara mais dinâmico; versátil;
Tanto para Visualizar paginas ; quanto visualizar paginas WYCIWYG ;
quanto para Visualizar a pagina onde esta a opção de ver código fonte;
----------------


Quero poder escolher facilmente; tanto o fundo de cor da pagina do Navegador;
Quanto; Quero escolher facilmente o fundo de cor da página que aparece quando
escolho "View Page Source"


O Padrão de fundo branco #FFFFFF é nocivo e desagradável para a navegação;
Estes fundos podem ser escolha do Usuário;




Atenciosamente;
Com grande satisfação e admiração.






TRADUÇAO



I have witnessed two bugs during the navigation that I consider of would be
importance;
 One bug; When I am forced to visualize page in Mozilla Navigator who configured
in deep # FFFFFF; harmful white that to the eyes during long readings; My
suggestion is of if implanting in the navigator an easy option; for example with
the left button of mouse to choose the deep one; OPTIONAL BACKGROUND; of the pagina;
 The WHITE color # FFFFFF; she is harmful to the eyes for long readings; This
appears during the visualization of pages in the Navigator; e also; This appears
when I want to verify the code source of the page; when I choose "VIEW PAGE SOURCE";
 The page generated in VIEW SOURCE is with DEEP WHITE # FFFFFF; That he is
harmful; for the excess of brightness of the light; This page must have DEEP of
color configured for the USER and not as a pagina of deep white standard #
FFFFFF only; As much for the Navigator; how much for option "VIEW SOURCE" of the
Navigator;
 The user must have the option to by itself configure the deep one of the pagina
of navigation; Pleasant colors can be chosen by the user; as for example; #
EEDDBB;#FEEECC;#FDF0E0;#FFF3DE;#FFEEDD;#FFF0E0;#FFE9D9;#FEF0E0 # FEF7E7;#FFFAEA;
BEING AS 
PERMANENT until the user wants others or the standard; An option can be created
in the Navigator as "Page Configurations"; This in such a way for the
visualization of the paginas in the navigator how much of the operation to see
the code source; or VIEW PAGE SOURCE; This in Editing Preferences directly or in
the Mouse; with the left button; Thus the Navigator is more dynamic; versatile;
As much To visualize paginas; how much to visualize paginas WYCIWYG; how much To
visualize the pagina where this the option to see code source; I want to be able
to choose easily; as much the deep one of color of the pagina of the Navigator;
How much; I want to easily choose the deep one of color of the page that appears
when I choose "View Page Source" The Standard of deep white # FFFFFF is harmful
and ackward for the navigation; These deep ones can be choice of the User; Yours
truly;


 With great satisfaction and admiration.



(Reporter)

Comment 8

14 years ago
(In reply to comment #5)
> Are you trying to say the viewsource background color should be configured by
> the user and can be diffrent from the default background color for websites?
> If this is true we should also set an option for the foreground.
> 
> Bug 141251 is simular but thinks backgrounds should be the same.
> Bug 62678 is the one that changed viewsource to use black on white


IbIdem

Bug 141251 - ViewSource does not respect my chosen colors
http://bugzilla.mozilla.org/show_bug.cgi?id=141251


Translation for the English

 Also I observed that the deep one; background of page VIEW-PAGE-SOURCE must
have a deep one; background configured by the user;
 The same if of; I observe; for the ackward pages of navigation that the reading
for having deep configured white;
 The huge idea to implant in browser Mozilla;
 SUGGESTION; In Navigator the Appearance as it follows;
 
------------------------------------------------------------------------------------
  | File Edit View Go Bookmarks Tools Widow Help        | #bgColor * 1 |     |
 
------------------------------------------------------------------------------------
 Suggestion of being made accurately as this drawing of the bar of navigation;
 Different for the Navigator and an other for the page of View-Page-Source;
 IMPORTANT
 As much for pages of WebSites; how much for the page of View-Page-Source Thus
the user can permanently control the appearance of the deep one of the pages;
How much to the Foreground this still can remain as standard; What it has caused
I bother is the configuration of deep white;
 SUGGESTION
 * the 1 With a click of mouse and page this configured as well as the others
that will come after; preventing the consuming of the visibility of the page; Or
better explaining in code;
 * 1
 < input value = "# bgColor * 1" onblur="document.bgColor='#bgColor * 1'"/>

 * 1 color Background configured by the user;
 As example # FFDFBF;#FFE3C6;#FFE7CC;#FFECD7;
 This in such a way for the pages of normal navigation if sites Web; How much
for the VIEW-PAGE-SOURCE page; equally; The pages would be decided how much the
deep white; As much the pages of Websites how much the pages generated in
View-Page-Source Being enough to the user to choose a time; being able to change
to the proper desire easily and; I have read extensive pages and the deep white
is harmful; ackward;
 Thus Mozilla Navigator will be more dynamic; it will be more practical; special;




Tradução para o Português


Também observei que o fundo; o background da página VIEW-PAGE-SOURCE deve ter um
fundo; background configurado pelo usuário;
O Mesmo se da; observo; para as páginas de navegação que desagradáveis a leitura
por terem fundo branco configurado;
A idéia grandiosa para implantar no browser Mozilla; SUGESTÃO ;
Em Navegador a Aparência como segue;

   ---------------------------------------------------------------------------
   | File Edit View Go Bookmarks Tools Widow Help      | #bgColor *1 |       |
   ---------------------------------------------------------------------------

Sugestão de ser feito exatamente como este desenho da barra de navegação;
Uma diferente para o Navegador e outra para a página de View-Page-Source;

 ---------       IMPORTANTE      ---------------------
Tanto para páginas de WebSites ; quanto para a página de View-Page-Source
Assim o usuário pode controlar permanentemente a aparência do fundo das páginas;
Quanto ao Foreground este ainda pode permanecer como padrão; O que tem causado
incomodo é a configuração de fundo branco;

 ---------       SUGGESTION      ---------------------
*1 Com um clique do mouse e a página esta configurada assim como as outras que
virão após;
evitando o desgaste da visibilidade da página;
Ou melhor explicando em código;
*1
<input value=" #bgColor *1 " onblur="document.bgColor='#bgColor *1'" />

*1 Background color configurada pelo usuário
Como exemplo #FFDFBF ;#FFE3C6 ;#FFE7CC ;#FFECD7 ;

Isto tanto para as páginas de navegação normal se sites Web;
Quanto para a página de VIEW-PAGE-SOURCE ; igualmente ;


As páginas estariam resolvidas quanto ao fundo branco;
Tanto as páginas de Websites quanto as páginas geradas em View-Page-Source

Bastando ao usuário escolher uma vez; podendo trocar ao desejo próprio e facilmente;

Tenho lido páginas extensas e o fundo branco é nocivo; desagradável;

Assim o Navegador Mozilla será mais dinâmico; será mais prático; especial;


Product: Browser → Seamonkey

Comment 9

13 years ago
*** Bug 236423 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
SeaMonkey isn't going to have a special prefence to set the background color of
ViewSource.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.