Switching from the download window causes another window to close.

VERIFIED WORKSFORME

Status

()

Toolkit
Downloads API
--
critical
VERIFIED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Kevin Ar18, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040115 Firebird/0.8.0+

When you save a file, the download manager appears.  However, if the file is
sufficiently large enough, the download manager will lag and Firebird will
become unresponsive for a few seconds.  If, during this time, you click on
another window, Firebird will close one of the browser windows.

Reproducible: Always
Steps to Reproduce:
1. Visit this URL:
http://edcw2ks36.cr.usgs.gov/Website/zipship/RequestSummary.jsp?areaList=38.19123989218327,35.79123989218329,-86.72951482479786,-91.46482479784365&prodList=NED&nedfmt=TIFF
2. Open the download manager and leave it open.
3. Click on one of the "download" links.
4. Wait for the data to process in the pop-up that appears.
5. When the file is ready to download, save it.
6. At this point the download manager should show up and Firebird should be
unresponsive for a few seconds.
7. Click on the download manager and then click on another windows in Firebird.

Actual Results:  
One of the Firebird Windows will be closed.

Expected Results:  
Nothing.
(Reporter)

Updated

14 years ago
Keywords: dataloss

Comment 1

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040120
Firebird/0.7+. Firebird never became unresponsive.
(Reporter)

Comment 2

14 years ago
Perhaps it has something to do with the video card.  Could someone perhaps test
this who has a pre-Geforce era video card?

A TNT, TNT2, or Vanta would be preferred.
Keywords: qawanted

Comment 3

14 years ago
Works for me too. At no point was Firefox unresponsive. I tested using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040302
Firefox/0.8.0+

Can you try to reproduce with a newer build?
Keywords: qawanted
QA Contact: aebrahim
(Reporter)

Comment 4

14 years ago
It doesn't occur on a newer build... (although I'm not sure of the reason).  If
it happens again at a later date, I'll reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.