Theme reported by themes page to be compatible does not show up after installing

VERIFIED INVALID

Status

()

--
major
VERIFIED INVALID
15 years ago
12 years ago

People

(Reporter: mukerjee2k2, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+

AFter installing the theme which is compatible ( Under the theme there is a
statement giving if the theme is compatible with the present build), the theme
does not show up under themes and hence no change occours.

On the other hand, on installing themes which are incompatible, they do show up
and ofcourse they are incompatible(scroll bar vanishes or some of the toolbars
dont occour).

This bug seems to be there starting with this 0.8 build that i am using 0.8.0 + 
I didnt see such a bug with earlier versions. Only the Mozilla Firebird Default
Theme works perfectly.

Reproducible: Always
Steps to Reproduce:
1.Install any 'compatible' theme from http://texturizer.net/firebird/themes/
2.Then go under Preferences - themes 
3.

Actual Results:  
The new compatible theme does not show up, though it is present in the folder 

Expected Results:  
Show the new installed theme and given the option to select the same.
Alan, David,

Is the detection busted on new nightlies?  I installed Doodle, which was just
updated three days ago, and it works fine, despite being listed as "not
compatible" with 0.8.0+

I know there's still the whole themeVersion mess to sort out, but this is
probably something that should be sorted out ASAP before 0.8.

Reporter, this is likely an issue with the version detection scheme.  Themes
older than a certain date probably don't work despite having matching
themeVersions.  We intend to have this addressed before 1.0

Comment 2

15 years ago
When did the userAgent change?  Mine still says Mozilla/5.0 (Windows; U; Windows
NT 5.0; en-US; rv:1.7a) Gecko/20040120 Firebird/0.7+

It is a trivial change to the javascript file.  However, this is not a bug in
Firebird.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

15 years ago
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.