The column headers appear in the wrong place (stagger headers mode) using Internet Explorer

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Query/Bug List
--
major
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: Paul Forrester, Assigned: Frédéric Buclin)

Tracking

2.16.1
Bugzilla 2.18
x86
Windows 2000
Bug Flags:
approval +
approval2.18 +

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: 

ID column heading appears 3rd from the left when ID column is actually 1st on 
the left. See attachment.

Reproducible: Always
Steps to Reproduce:
This is one way to reproduce the problem. There may well be other ways. I 
haven't yet tested with different conbinations of columns, for example:
1. Go into 'change columns'
2. Make sure all fields are ticked except platform, product, version, os, 
votes, full summary.
3. Select 'Stagger headers' option
4. Submit column changes.
5. Now when I run a query, the ID column heading is out of place.
Actual Results:  
Whenever I run a query, the ID column heading is out of place. ID column 
heading appears 3rd from the left when ID column is actually 1st on the left. 
See attachment.

Expected Results:  
The ID column heading should appear abve the ID column data.
(Reporter)

Comment 1

14 years ago
Created attachment 139997 [details]
This is a bug list showing the ID column out of place
(Reporter)

Updated

14 years ago
Version: unspecified → 2.16.1
Looks to me like it's in the right place, but it's aligned right when it should
be aligned left....  weird.
Summary: The ID column heading eppears in the wrong place → The ID column heading eppears in the wrong place (stagger headers mode)
This appears to be either something you locally broke or it's been fixed at some
point.  I can't reproduce it on 2.16.4 or cvs tip.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 4

13 years ago
You couldn't reproduce it because you're all browser-snobs. :)

This is easily reproducible using IE 6.0 to look at a bug list. Stagger the 
headers, and the output will appear as it does on the attachment. In Mozilla, 
Firefox, and Netscape it looks like it's supposed to.

This is still an issue as of 2.18rc3.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

13 years ago
Confirming this bug with IE 6 and actual version on b.m.o + 2.18rc3
Flags: blocking2.20?
Flags: blocking2.18?
Summary: The ID column heading eppears in the wrong place (stagger headers mode) → The column headers appear in the wrong place (stagger headers mode) using Internet Explorer
Oh, yippie, yet another MSIE workaround. ;)

What in the syntax is breaking IE, do we know?
(Assignee)

Comment 7

13 years ago
This looks really ugly with IE6, which remains the most used browser. Requesting
blocking and arising the severity to major.
Severity: trivial → major
(Reporter)

Comment 8

13 years ago
I can confirm that noticed the bug on IE 6. You can see that it is IE from the 
screenshot attached.
(Assignee)

Comment 9

13 years ago
Created attachment 168083 [details] [diff] [review]
remove right alignment of bug IDs

In buglist.css, we can read:

/* Right align bug IDs. */
.bz_id_column { text-align: right; }


but in table.html.tmpl, we have (for headers):

    <tr align="left">


So Gecko like browsers align bug numbers and the ID header to the left because
they don't understand the <COLGROUP> and <COL> tags (at least there
attributes), while Internet Explorer align them to the right because IE
understands them correctly! I don't know which one takes precedence, either the
CSS file applied to the COL tag or the attribute applied to the TR tag so that
I cannot say if IE is right when right aligning the ID header. But what is sure
is that Gecko like browsers have never respected the .bz_id_column {
text-align: right; } instruction for bug numbers!

So what I suggest is to remove this instruction, first because Gecko like
browsers do not understand it and second because this causes the ugly display
shown in the previous attachment.

What we could do (and it works for all browsers) is to add a TH {text-align:
left} just after the previous instruction so that the header is displayed on
the left even for IE, as expected. Unfortunately, the text is now too far on
the left compared to bug numbers which are still aligned to the right. Still
ugly then so it's a bad idea! :(
Assignee: justdave → LpSolit
Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Attachment #168083 - Flags: review?(bugzilla)
(Assignee)

Comment 10

13 years ago
Created attachment 168085 [details] [diff] [review]
remove right alignment of bug IDs, v2

here, we keep the class... but empty!
Attachment #168083 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Attachment #168085 - Flags: review?(bugzilla)
(Assignee)

Updated

13 years ago
Attachment #168083 - Flags: review?(bugzilla)
Comment on attachment 168085 [details] [diff] [review]
remove right alignment of bug IDs, v2

r=glob
Attachment #168085 - Flags: review?(bugzilla) → review+
Flags: blocking2.20?
Flags: blocking2.18?
Flags: approval?
Flags: approval2.18?
Yeah, looks like the relevant information about Gecko's (lack of) support for
this is at bug 915 comment 162 and following.

But I want Myk's vote on how to fix...  I'm thinking we want the bugs
right-aligned, since that's usually what you do with a column of numbers. 
Should we change the HTML attribute to do align="right" instead of "left"?
Target Milestone: --- → Bugzilla 2.18

Comment 13

13 years ago
FWIW, I think we need align="right".
Comment on attachment 168085 [details] [diff] [review]
remove right alignment of bug IDs, v2

for myk: we had conflicting align:right and align:left here.  The patch is only
removing the align:right, which leaves the align:left.	Which one do we really
want to keep?  Should that colunm be right-justified?
Attachment #168085 - Flags: review?(myk)
Myk is gone until Monday
Flags: approval?
Flags: approval2.18?
Whiteboard: patch awaiting review from Myk
Comment on attachment 168085 [details] [diff] [review]
remove right alignment of bug IDs, v2

It's not clear that right-aligning the ID column is better than left-aligning
it.  The column contains numbers, but those numbers may not be scanned
vertically often enough in a way that makes right-alignment useful.

Nevertheless, it's definitely not useful when staggering columns, since the
right edge of staggered column headers doesn't line up with the right-edge of
the columns themselves.

This patch is a reasonable fix for the immediate problem, but down the road we
should see if there's something better than staggering headers, like
abbreviating the ones likely to top narrow columns, which I could even see
becoming the standard and only view if good means exist to match abbreviations
with their expansions (f.e. tooltips).
Attachment #168085 - Flags: review?(myk) → review+
(Assignee)

Updated

13 years ago
Flags: approval?
Flags: approval2.18?
Whiteboard: patch awaiting review from Myk → patch awaiting approval
Flags: approval?
Flags: approval2.18?
Flags: approval2.18+
Flags: approval+

Comment 17

13 years ago
Frederic: could you make a patch for 2.18 as well?
(Assignee)

Comment 18

13 years ago
(In reply to comment #17)
> Frederic: could you make a patch for 2.18 as well?

vladd, this patch applies cleanly to the 2.18 branch. You only have to update
the path from skin/standard/buglist.css to css/buglist.css.

Do you want a new patch with the path updated? I remember a mail from myk who
said you only have to updated the link to the right path or something like that.

Comment 19

13 years ago
Frederic: thanks! I didn't need a new patch, but I needed to know what I have to
do to backport it to 2.18 :-)


Checking in skins/standard/buglist.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/buglist.css,v  <--  buglist.css
new revision: 1.7; previous revision: 1.6
done

Checking in css/buglist.css;
/cvsroot/mozilla/webtools/bugzilla/css/Attic/buglist.css,v  <--  buglist.css
new revision: 1.2.4.4; previous revision: 1.2.4.3
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: patch awaiting approval
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.