Closed Bug 232348 Opened 21 years ago Closed 21 years ago

Mozilla 1.6 locks up on leaving entry field with TAB

Categories

(SeaMonkey :: General, defect)

x86
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 232368

People

(Reporter: Harald, Unassigned)

References

()

Details

(Keywords: hang, regression, testcase)

Attachments

(1 file)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.6) Gecko/20040113

Mozilla 1.6 blocks/lock up on the above homepage, when trying to add a comment,
after typing in the name in the Autor field (replacing Gast) and pressing TAB
(or leaving the fields using the mouse ?).
Mozilla is completely unresponsive has to be killed.

This doesn't happen in Moz 1.6a. I didn't test with 1.6b

Reproducible: Always
Steps to Reproduce:
1. type your name in the Autor field, replacing "Gast"
2. press TAB
3.

Actual Results:  
Mozilla locks up, must be killed.

Expected Results:  
Move focus to the message entry field (Kommentar).
I can't reproduce this.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040127
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

<tab> from the Author field seems to send the input to the poll submit button
(unsure about that). If i do a text find for 'c', the first selected text is c
in 'Archiv'. Mozilla still functions, and I can do other things on the page.

After a few times, then the cursor dropped to the <textarea> below the Author
field as it probably should have to begin with (?).
I can reproduce this behaviour using the following setups:
latest pre0.8 Firebird nighty (Gecko/20040120 Firebird/0.7+) running on:
1. WinNT 5.1 (Win XP SP1a German)
2. Win98SE (German)

Firebird locks up and eats 100% CPU. Must be killed.

reproducible: always
*fresh profile*


Although: cannot reproduce in Mac OS X 10.2.8 using Moz1.6

might be a Win specific problem.
Keywords: hang
Just noticed bug 232368, which sounds very much like this, and I was able to
reproduce the problem with 1.7a and 1.6, but not 1.4.1 or Firebird 0.7.
Confirming in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040120 Firebird/0.7+ as per testcase.
confirming hang on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040127
Confirming in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Attached file testcase
load the testcase and hit TAB. hangs linux trunk 2004012708
also regressed between linux trunk 2003110608 and 2003110708
and similar testcase to bug 232368

marking dupe of "Hang when tab into input element with onBlur handler"

*** This bug has been marked as a duplicate of 232368 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Keywords: regression, testcase
OS: Windows NT → All
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: