Junkmail filter checks marked as deleted imap-mails

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
minor
RESOLVED INCOMPLETE
15 years ago
10 years ago

People

(Reporter: Heiko Adams, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040120 Firebird/0.7+

If the "mark as deleted" option is activated and message filters have moved
messages from the inbox to specific folders the junkmail filer still checks the
as deleted marked messages.

Reproducible: Always
Steps to Reproduce:
1. Enable the "mark as deleted" option for an imap account
2. Specify an message filter
3. get your mail via imap

Actual Results:  
Junkmail filter checks as deleted marked mail

Expected Results:  
Junkmail filter should ignore mails which are marked as deleted

Updated

15 years ago
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Networking: IMAP
Ever confirmed: true
Product: Thunderbird → MailNews
QA Contact: grylchan
Version: unspecified → 1.0 Branch
(Assignee)

Comment 1

15 years ago
I think this is fixed in 1.7 - when we move a message, we mark it as seen in the
source folder. That should deal with your problem, right?
(Reporter)

Comment 2

15 years ago
If that makes the junkmail filter stops checking those messages, yes that deals
with my problem.
(Assignee)

Comment 3

15 years ago
it should - resolving wfm, since this should be fixed on the trunk.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

14 years ago
Sorry, but it's not Fixed. Thunderbird's (version 0.7+ (20040816)) Junkmail
Filter still checks mails that are marked as deleted (i.e. by a filter which has
moved the mail).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

14 years ago
Component: Networking: IMAP → General
Product: MailNews → Thunderbird
Version: 1.0 Branch → unspecified

Comment 5

14 years ago
are these related? bug 208950
QA Contact: grylchan → general

Comment 6

10 years ago
still see problem using latest TB?
Severity: normal → minor
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago10 years ago
Resolution: --- → FIXED
Whiteboard: closeme 2008-07-24

Updated

10 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
RESO INCO per lack of response to question in last comment. If you feel this change was made in error, please respond to the bug detailing your reasons why.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2008-07-24
You need to log in before you can comment on or make changes to this bug.