Emails with empty from field are categorised in personal address book

RESOLVED DUPLICATE of bug 202169

Status

defect
RESOLVED DUPLICATE of bug 202169
16 years ago
11 years ago

People

(Reporter: pouya, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7a) Gecko/20040116

I have set up a filter to label any messages from people in my address book as
"personal" and lately I noticed that some spam messages from people not in my
address book are being coloured green as well. This affects the spam filter as
well, so that it doesn't run the spam filter on the message since it thinks it's
from someone in my address book.

Looking at the source of the email, I see the headers:
From: "Glenna Stacy" <>
Reply-To: "Glenna Stacy" <>

And apparently the empty email address <> is thought to be in my address book.

Reproducible: Always
Steps to Reproduce:
This is a dupe, but it has additional detail; I'll refer the other bug back to 
this one.

*** This bug has been marked as a duplicate of 202169 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.