If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Single window mode to Mozilla MailNews and/or Thunderbird ?

VERIFIED DUPLICATE of bug 218999

Status

Thunderbird
Message Compose Window
--
enhancement
VERIFIED DUPLICATE of bug 218999
14 years ago
13 years ago

People

(Reporter: Nicolas VERITE, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Since Mozilla Browser and Firebird have the single window mode feature,
should/could Mozilla MailNews and/or Thunderbird have the same feature ? (I
would strongly like that feature)

Having multiple windows open for one application is very disturbing for many
desktop users (and window managers), since you have to manage your windows'
sizes and positions, and the window manager has to reorganize the
windows-list/task-bar/button-bar all the time.

Multiple window applications are time and resources consuming... and boring ! ;-)

The issue is adressed with the tab-organized window in modern browsers.

The tab craziness is in the air ;-) should the single window mode use tabs ? One
tab for the folders/message-list/(pre)view and another tab for mail composition
including the adressbook.

Reproducible: Always
Steps to Reproduce:
1.CTRL+M or ENTER while a message selected

Actual Results:  
It opens up another new window.

Expected Results:  
Switch to mail-composition tab ;-)

Comment 1

14 years ago
Please search before filing bugs.

*** This bug has been marked as a duplicate of 218999 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.