doesn't show link text if url contains "click_"

RESOLVED EXPIRED

Status

--
minor
RESOLVED EXPIRED
15 years ago
13 years ago

People

(Reporter: gnebulon, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030624

If I have a link like <a href="blah.com?click_id=5"%gt;TEXT</a>, then
TEXT will not be displayed.  I'm as baffled as you are.  Probably more.  But if
I get rid of any one of the characters of "click_", then it displays correctly.
 This also works with <a href="blah.com/click_cherry.html">TEXT</a>,
etc.  I don't understand it.

Reproducible: Always
Steps to Reproduce:
Make a web page, and inside, put the text:
(<a href="blah.com?click_id=5"%gt;TEXT</a>)
or any other text where the characters "click_" are contained in the "href" portion.

Actual Results:  
TEXT does not show up on the page.  Instead, you'll just see (), and it will not
be a link.

Expected Results:  
The phrase TEXT should show up, blue and underlined, as a link to
blah.com?click_id=5.

Comment 1

15 years ago
you are comparing apples to oranges, can you attach a testcase?

<a href="blah.com?click_id=5"%gt;TEXT</a>
<a href="blah.com/click_cherry.html">TEXT</a>
can you attach your userContent.css file to this bug?

Comment 3

15 years ago
Do you use privoxy or another add filtering proxy?
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.