Closed Bug 232438 Opened 21 years ago Closed 20 years ago

cleanup palm sync category <-> AB mappings

Categories

(MailNews Core Graveyard :: Palm Sync, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

Attachments

(4 files)

There are a few problems in the mapping between AB's and categories. The
upcoming patch makes the following changes:

1. Only delete palm categories if the corresponding Moz AB has been deleted. We
tell this by setting the position pref for the moz AB to 0. Previously, we just
assumed that missing AB's had been deleted, which caused problems in some
situations.

2. Map Moz Personal Address Book to "Personal" category on Palm.

3. Ignore ldap directories when figuring out which AB's to sync

4. If Moz AB has an existing card with the same display name as a Palm Category,
don't add the card to the Moz AB.
Attached patch proposed fixSplinter Review
this patch could use a little cleaning up, but it should fix a whole host of
problems.
Attachment #140074 - Flags: superreview?(mscott)
Attachment #140074 - Flags: superreview?(mscott) → superreview+
the dup detection code was wrong, because the arg is really a char *, not a
TCHAR *. Also, set the ab palm card id of the existing ab card.
Attachment #140277 - Flags: superreview?(mscott)
Attachment #140277 - Flags: superreview?(mscott) → superreview+
one more place where Personal needs to match Personal Address Book
Attachment #140314 - Flags: superreview?(mscott)
Attachment #140314 - Flags: superreview?(mscott) → superreview+
This fixes handling of the prefer work address pref so that we handle two line
addresses, extend to work city, state, zip, and country, don't hardcode URI for
pab but map actual ldap2_servers.pab to Personal category, and ignore which
contact field is used for the purpose of comparing cards for equality - this
will fix a cause of dups when doing a first time sync after switching conduits.
Attachment #141892 - Flags: superreview?(mscott)
Attachment #141892 - Flags: superreview?(mscott) → superreview+
all fixes checked into m4 branch and trunk. I'm going to resolve this as fixed.
We can open new bugs for remaining issues.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Product: MailNews → Core
*** Bug 204661 has been marked as a duplicate of this bug. ***
Product: Core → MailNews Core
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: