If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mail automatically removed from trash folder when it should not be removed

RESOLVED INCOMPLETE

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED INCOMPLETE
14 years ago
9 years ago

People

(Reporter: Everette Mills, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-11-05)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla Thunderbird 0.5a (20040120)

This problem has been vexing me for the last several versions at least 0.4b.

I have placed mail in the trash folder.
Then the mail disappears from the folder after a certain period of time.
I DONT have delete mail on exit marked. 
I have it marked to move the mail to the Trash folder.

I have finally started carefully watching the order recieved number in the 
trash folder.  I will "lose" the oldest serveral messages every day or two.

I have checked with my ISP and they are not deleting any emails.
I dont have this problem when I am traveling and check via webmail.

Note: I have a script that runs every month and retrieves any message that is a 
month old from the server and copies to a local archive for long term storage.  
So that is the reason I dont want trashed email actually delted.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
pop? Imap? 
(Reporter)

Comment 2

14 years ago
IMAP

I can attach the log file if needed, but it didnt happend the last time that I 
started up TB. 
(Reporter)

Comment 3

14 years ago
This problem continues to happen.  

It doesnt seem to depend on the amout of mail in my trash folder or the data the
mail was recieved.

Is there anything I can do to log or provide better information concerning this
problem.
(Reporter)

Comment 4

14 years ago
Created attachment 140910 [details]
Prefs for TB, might explain why I am losing emails
(Reporter)

Updated

14 years ago
Severity: normal → critical
(Reporter)

Comment 5

14 years ago
Created attachment 143243 [details]
Imap log describing the action on trash folder

Comment 6

13 years ago
I have been having this exact same problem... I too contacted my ISP and they
couldn't find anything.  I also see the exact same patterns the original person
was seeing.  For me it's usually about 6 days and then I start seeing stuff
disappear on me automatically.

I didn't notice this happening when I was using Mozilla Email Client, but just
started seeing it when I installed Thunderbird when 1.0 got released.

Comment 7

13 years ago
I see this too. Caught me by surprise and I lost years of non-spam trash I was going to use for junkmail 
training. :-/

Thunderbird version 1.0 (20041206)
Mac OS X 10.3.8
Courier-IMAP server using SSL

Set up in Thunderbird as a single account and many identities. Like Everette I have it set to put deleted 
messages in Trash and have it NOT set to expunge trash on exit.

Only extension is Engimail 0.89.6
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 9

12 years ago
Keeping bug alive.

Comment 10

12 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 11

12 years ago
This bug still exists.  I check for a solution with each new release.

Comment 12

12 years ago
Could this be connected to the Junk auto purge preference. I have two users who are having the same problem and both problems corresponded with them having Junk autopurge switched on and the timings match up also. Still a bug, though. Andy.
(Reporter)

Comment 13

12 years ago
I dont have the auto purge feature for junk mail turned on.

I believe the issue is some combination of my settings and those of my ISP.  There helpdesk has been able to replicate the issue, but neither of us have been able to determine the cuase.

Comment 14

12 years ago
I have this problem as well. 
QA Contact: front-end

Updated

9 years ago
Assignee: mscott → nobody
still see problem?
Whiteboard: closeme 2008-11-05
RESO INCO per lack of response to last question. If you feel this change was made in error, please respond to the bug with your reasons why.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.