[rte] Editable content stops working if its container is hidden and shown again

RESOLVED DUPLICATE of bug 217205

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 217205
14 years ago
14 years ago

People

(Reporter: Ere Maijala (slow), Assigned: Joe Francis)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
The Rich Text Editor (Midas) on an iframe stops working if the element that
contains the iframe is hidden and shown again. From what I can see, the
presshell gets killed and the editor gets screwed. 

I'll attach a test case.
(Reporter)

Comment 1

14 years ago
Created attachment 140091 [details]
Test case

This test case is modified from the original
(http://www.mozilla.org/editor/midasdemo/) Rich Text Edit Demo. I've added two
links to the bottom, Hide and Show. To see the problem, try the editor (works),
click hide, click show and try the editor again (can't edit, no caret).
(Reporter)

Comment 2

14 years ago
Whoops, I should've found the earlier bug about this.

*** This bug has been marked as a duplicate of 217205 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.