Arrow keys not working in Account Wizard

VERIFIED FIXED in M14

Status

SeaMonkey
MailNews: Account Configuration
P2
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2000010515M13: Linux 6.0, Mac 8.5.1
Build 2000010609M13: NT4

Overview: Arrow keys are not working in the Account Wizard text boxes.

Steps to reproduce:
1. Open Account Setup
2. Select New Account button to launch the Account Wizard
3. Select the Mail radio button, select Next button to advance to the Identity
dialog
4. Type some text in the "Your Name" field
5. Try navigating backwards using the arrow keys

Actual Results: The cursor does not move backwards when using the < arrow key.
By clicking I placed the cursor in the beginning of the field and tried using
the > arrow and no response. Also tried the arrow keys on the Num Pad and they
also do not work.

Expected Results: The arrow keys should move the cursor in the expected
direction.

Additional Information:
- The Delete button works
- I placed the cursor at the beginning of the field and pressed Ctrl+Right Arrow
and again no response. It should have placed the cursor at the end of the field.
- The arrow keys are working in other areas such as Account Setup and
Preferences.
(Assignee)

Comment 1

18 years ago
reassign to buster - editor stuff. this is in a modal dialog, on top of another
modal dialog if that makes a difference. Adding saari and akk because this is
keybinding related
(Assignee)

Updated

18 years ago
Assignee: alecf → buster
(Assignee)

Comment 2

18 years ago
argh, reassign didn't work. buster/akk/saari please see my previous comments

Comment 3

18 years ago
This should presumably use the editor controller automatically, since it's a
text field.  But there are other cases where the right controller doesn't get
called, e.g. arrow keys (and most other keybindings) aren't working right in the
browser urlbar, bug 14026 (because I think it's the same problem as the fact
that copy/paste don't work in the browser window, though I could be wrong about
that).

This is probably a hyatt/saari problem.  Cc'ing hyatt.

Updated

18 years ago
Assignee: buster → hyatt

Comment 4

18 years ago
let's make it official.  assigning to hyatt. cc self.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

18 years ago
Assignee: hyatt → don
Status: ASSIGNED → NEW

Comment 5

18 years ago
This window just needs a keyset.  Assigning back to don who can give it to Ben
Goodger or something.

Updated

18 years ago
Assignee: don → rgoodger
Priority: P3 → P2
Target Milestone: M13 → M15

Comment 6

18 years ago
I don't think we need to fix this for beta 1 ...
would love to set this up, but have too much shit going on in other areas. 
assigning back to alec (sorry!) (if its as simple as hyatt says, I don't feel so 
bad about reassigning ;)
Assignee: rgoodger → alecf

Comment 8

18 years ago
Is this really a dup of 21935?

Comment 9

18 years ago
Sorry for the spam (I have been doing a lot of spam lately ;-)Adding myself to 
the CC: list and making the bug link "linkified". Bug 21935.
(Assignee)

Comment 10

18 years ago
oops, fixed this a while back
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: lchiang → nbaca
Target Milestone: M15 → M14
(Reporter)

Comment 11

18 years ago
Build 2000-02-11-08M14: NT4
Build 2000-02-11-11M14: Linux 6.0
Build 2000-02-11-12M14: Mac 8.6.1
Verified Fixed. Regular arrow keys and Ctrl+right arrow and Ctrl+left arrow 
moves cursor as expected. Thanks!

Note: The num pad arrow keys are not working on Linux but work on Windows. I'll 
look for a specific bug on this issue and log one if it doesn't exist.
Status: RESOLVED → VERIFIED

Comment 12

16 years ago
Mass removing self from CC list.

Comment 13

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.