Scrollbars overpaint DIVs on Mac

RESOLVED DUPLICATE of bug 191265

Status

Core Graveyard
GFX: Mac
RESOLVED DUPLICATE of bug 191265
15 years ago
10 years ago

People

(Reporter: jhp (no longer active), Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
This is actually an offshoot of bug 126263 - Scrollbars overpaint DIVs.  That
bug was created due to a customer case where a DHTML menu would appear to paint
'behind' the scrollbar.  Take a look at the customer case
(http://bugzilla.mozilla.org/attachment.cgi?id=109667&action=view).  If you
click on "File" in the page, it will open a DHTML menu; then click on "Print" or
"Close" to open a submenu.  Here you will see that the scrollbar paints over the
menu.

The problem is that the native scrollbar actually sits on top of the window,
whereas the DHTML menus are actually drawn by mozilla directly on the window. 
The fix in bug 126263 was to remove native scrollbars and have Mozilla create
them, with the platforms look and feel.

So we need to either back out Mac OS X native scrollbars and revert to Mozilla
drawn scrollbars, or find a way to allow the native scrollbars to be overpainted
by DIVs.
(Reporter)

Comment 1

15 years ago
Adding some other Mac folks.  Note that this affects Camino, also.
(Reporter)

Comment 2

15 years ago
Created attachment 140116 [details]
another testcase

Reworked testcase from bug 126263.  This one has several HTML elements under a
DIV.  Only the scrollbars appear above the DIV.  Also, this is not an issue
under Safari; plus Safari has thinner scrollbars!
this is a dupe of a much older bug, fwiw. we've had this problem for years.
(Reporter)

Comment 4

15 years ago
I couldn't find a bug that specifically dealt with this issue, so I opened a new
one.  If you can find the dup, please let me know.

Also, was this also a problem before bug 188254 (Land chimera's form controls on
the trunk) was landed?
this started when we landed native scrollbars in mac mozilla, which was easily a
year and a half ago, if not longer.

i think this can be duped to 191265, no?
(Reporter)

Comment 6

15 years ago
yeah, that looks to be the correct dup.  i didn't read the whole bug. thanks.

dup -> bug 191265

*** This bug has been marked as a duplicate of 191265 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.