Closed Bug 232481 Opened 21 years ago Closed 20 years ago

insane loop in SMIME test script

Categories

(NSS :: Test, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nelson, Assigned: bishakhabanerjee)

Details

the test script smime.sh contains the following code:

  html_msg $ret 0 "Create Multiple Recipients Enveloped Data Alice" "."
  if [ $ret != 0 ] ; then
        i=0
        echo "cp -r ${R_ALICEDIR} ${R_ALICEDIR}.trouble"
        cp -r ${R_ALICEDIR} ${R_ALICEDIR}.trouble
        while [ $i -lt 100 ] ; do
            echo "will attempt to list the certs in the db `expr 100 - $i` more
times"
            echo "certutil -L -d ${P_R_ALICEDIR}"
            certutil -L -d ${P_R_ALICEDIR}
            echo "certutil -L -d ${P_R_ALICEDIR} -n dave@bogus.com"
            certutil -L -d ${P_R_ALICEDIR} -n dave@bogus.com
            sleep 30
            i=`expr $i + 1`
        done
  fi

Doing this loop 100 times with a 30 second sleep in it accomplishes nothing
that I can see, except delaying the results for 3000 seconds (50 minutes),
and wasting developers' time.  

Please remove this loop, or reduce the loop count from 100 to 2.
I just happened across this bug (the catchy subject drew me in :).  I actually
remember what that loop was for, Sonja put it in to test some intermittent
S/MIME QA failures seen on a (Linux?) machine at Sun.  I think the problem was
not very reproducible and eventually went away (probably when the machine was
decommissioned).

Thus I would suggest just removing the loop entirely.
removed the loop and checked in. Marking fixed.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.