Firebird does not show up on Open With menu

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
This makes it so Windows has problems if someone wants to do a manual
association with "Open With" on an HTM file. If I rename the executable
"Firebird.exe" it will allow me to associate manually. If not, it won't appear
in the list after I browse to the folder and choose it. I'd have to hack the
registry manually. Since Firebird has issues with associations, we are required
to associate manually.

Comment 1

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040128
Firebird/0.7+

Can you include your user agent string and steps to reproduce?
(Reporter)

Comment 2

14 years ago
Before I respond, when the Mozilla Thunderbird executable is named
thunderbird.exe (a more reasonable name), Firebird's executable should not be
named MozillaFirebird.exe -- that's inconsistent (plus too long). So whether or
not anyone can reproduce what problem I had, this bug is still valid...

With that being said...

I don't know why the UA string would be relevant, but I have:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040115
Firebird/0.8.0+

I have Windows XP SP1.

1) Make an .htm file.
2) Make sure Mozilla Firebird is not already associated with any web content.
3) Right click on .html file, choose Properties.
4) Choose "Change..."
5) Choose "Browse..."
6) Navigate to your Firebird directory
7) Choose MozillaFirebird.exe <- Make sure the name matches!
8) MozillaFirebird.exe doesn't appear on the list of applications
9) No way to associate.

Notice that if I change the name of MozillaFirebird.exe, the problem doesn't
happen. All I can say is I tried out FirebirdSetup.exe, so I don't know if that
has anything to do with you not being able to reproduce the results.

Comment 3

14 years ago
WFM. Are you using the installer or the zip?

I don't think that MozillaFirebird.exe will be named Firebird.exe because once
it hits 1.0, it won't be known as Firebird, it'll be known as Mozilla Browser.
In the interim, I don't think it's worth it to change and break people's shortcuts.
(Reporter)

Comment 4

14 years ago
Did you run the installer? I said I had used the installer named "FirebirdSetup.exe"

This is kinda a hard bug for me to try to reproduce on my own from scratch
because the installer has already messed with my registry and I don't want to
run uninstall. When I unassociate .HTM files and change Firebird.exe back to
MozillaFirebird.exe and try it again, I have the same problem. Explorer does not
like MozillaFirebird.exe for some reason.

This is all the reference to \Firebird.exe in my registry (After I changed the
name and associated .HTM files with Firebird.exe):

HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\ShellNoRoam\MUICache
(C:\Programs\Communications\Firebird\Firebird.exe)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App
Paths\MozillaFirebird.exe (Default=C:\Programs\COMMUN~1\Firebird\Firebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003_Classes\Applications\Firebird.exe\shell\open\command
(Default="C:\Programs\Communications\Firebird\Firebird.exe" "%1")
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Classes\Applications\Firebird.exe\shell\open\command
(Default="C:\Programs\Communications\Firebird\Firebird.exe" "%1")
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\OpenSaveMRU\exe
(b=C:\Programs\Communications\Firebird\Firebird.exe)

This is all the references to MozillaFirebird.exe in my registry (After I
changed the name and associated .HTM files with Firebird.exe):

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App
Paths\MozillaFirebird.exe
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\MozillaFirebird.exe
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003_Classes\Applications\MozillaFirebird.exe
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Classes\Applications\MozillaFirebird.exe
HKEY_LOCAL_MACHINE\SOFTWARE\FullCircle\TalkBack\NetscapeMozillaFirebirdWin322003092508
(MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\ShellNoRoam\MUICache
(C:\Programs\Communications\Firebird\MozillaFirebird.exe)
HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla Firebird\0.7+. (en)\Main
(PathToExe=C:\Programs\Communications\Firebird\MozillaFirebird.exe)
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla Firebird 0.7+.\bin
(PathToExe=C:\Programs\Communications\Firebird\MozillaFirebird.exe)
HKEY_LOCAL_MACHINE\SOFTWARE\FullCircle\TalkBack\NetscapeMozillaFirebirdWin322003092508
(MozillaFirebird.exe=C:\Programs\Communications\MozillaFirebird\MozillaFirebird.exe)
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\MozillaFirebird.exe\shell\open\command
(Default="C:\Programs\Communications\Firebird\MozillaFirebird.exe")
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\MozillaFirebird.exe\InstallInfo
(ReinstallCommand="C:\Programs\Communications\Firebird\MozillaFirebird.exe"
-silent -nosplash -setDefaultBrowser )
HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\MozillaFirebird.exe\DefaultIcon
(Default=C:\Programs\Communications\Firebird\MozillaFirebird.exe,0)
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\command
(Default=C:\Programs\Communications\Firebird\MozillaFirebird.exe %1)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003_Classes\Applications\MozillaFirebird.exe\shell\open\command
(Default="C:\Programs\Communications\MozillaFirebird\MozillaFirebird.exe" "%1")
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Classes\Applications\MozillaFirebird.exe\shell\open\command
(Default="C:\Programs\Communications\MozillaFirebird\MozillaFirebird.exe" "%1")
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\mozilla.org\Mozilla
Firebird\0.7+. (en)\Main
(PathToExe=C:\Programs\Communications\Firebird\MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Mozilla\Mozilla
Firebird 0.7+.\bin
(PathToExe=C:\Programs\Communications\Firebird\MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xml\OpenWithList
(d=MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.html\OpenWithList
(f=MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.htm\OpenWithList
(c=MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\OpenSaveMRU\exe
(c=C:\Programs\MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\OpenSaveMRU\exe
(a=C:\Programs\Communications\Firebird\MozillaFirebird.exe)
HKEY_USERS\S-1-5-21-1454471165-484763869-1343024091-1003\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32\OpenSaveMRU\*
(d=C:\Programs\MozillaFirebird.exe) *



* This was just creating MozillaFirebird.exe for testing purposes, and the same
problem happened.

Note: Some of these values are incorrect, and I replaced them manually after
pasting here.

Comment 5

14 years ago
Yes, I'm running an installer build. Inside the properties window, does it list
Firebird as a Recommended Program? For me it does, that may be the difference.

If you change MozillaFirebird.exe to MozillaFirebird1.exe, does this also solve
your problem?
(Reporter)

Comment 6

14 years ago
When I changed it to MozillaFirebirda.exe earlier today, it worked properly. It
definately does not like MozillaFirebird.exe

It is in my list of recommended programs now because I used Firebird.exe
earlier. Its in the list as Firebird.exe, though. MozillaFirebirda.exe, etc
would appear in the list of Other Programs.

This seems all very wacky and has my head spinning. You know... It almost
reminds me of how sometimes when I play a sound file, the wrong file plays and
MSN Messenger grabs a .wav file from my HalfLife2 folder that has the same name.

I'm gonna run a virus check, methinks.

Comment 7

14 years ago
This is probably a registry thing.  As for naming it MozillaFirebird vs
Thunderbird.exe, that is a different debate and is probably somewhere else in
bugzilla.

Changing summary to match the problem.

Severity: major → normal
Component: Migration → General
OS: All → Windows 2000
Summary: Firebird should not be named MozillaFirebird.exe → Firebird does not show up on Open With menu
(Reporter)

Comment 8

14 years ago
Agreed. Due to an issue with the latest security patch from Microsucks causing
my mouse and keyboard to not work in Windows (can't even log in), I will to
recover, backup, then install a new copy of the OS fresh, so the registry is
going to be gone. Therefore, since I can't provide any more info, I'm going to
mark this WORKSFORME until its reproduced. If it doesn't happen to anyone else
ever, that's good. If it does, hopefully they report it, and hopefully we can
figure out what in the registry is causing this.

It might have been caused by the fact I'm a developer and therefore have tested
and built, etc a lot of builds.

If anyone has any suggestions of what specifically within the registry might
have caused it, we could try to re-create those conditions. Perhaps there is a
KB article someone knows of? I don't have time to look into this now.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.