no proxy: requires spaces between items

VERIFIED WORKSFORME

Status

()

Firefox
Address Bar
--
major
VERIFIED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Scott, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

After upgrading my workstation from Windows 2000 Professional to Windows XP, I
experienced the following behavior:
1) I am using a http proxy
2) Proxy settings have been set to no proxy for localhost or 127.0.0.1
3) I am accessing http://localhost:port/application
4) After upgrading, the url gets changed to www.localhost.com, which of course
is not what I want.
5) I can never access localhost, unless I turn off proxy, then it works fine.
6) This only occured after upgrading to XP

Reproducible: Always
Steps to Reproduce:
1. See above
2.
3.

Actual Results:  
Browser stalls trying to access www.localhost.com - never accesses my localhost.

Expected Results:  
Browser should not use proxy and should bring up my localhost.

The behavior of autocomplete does not occur if the proxying is turned off. This
behavior is only exhibited with Firebird, and none of the other browsers.

Comment 1

14 years ago
Was this fixed by the fix for bug 184433?  (Test in a trunk nightly from today
or newer: http://ftp.mozilla.org/pub/mozilla.org/firebird/nightly/latest-trunk/)
(Reporter)

Comment 2

14 years ago
I tested the latest build, and still get the same results. The real issue seems 
to be that the autocomplete changes http://localhost to 
http://www.localhost.com. This would seem to be a bug to me, since the URL 
change does not happen when not using the proxy. Localhost should be an 
exception to the URL autocomplete feature.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 184814 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
sipaq: I don't think this is a dup.

Comment 5

14 years ago
You're right, Jesse.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

14 years ago
If this happens only w/ the proxy, then you probably have a problem w/ the proxy.

(Reporter)

Comment 7

14 years ago
It is not the proxy, as far as I can tell, because I only started having this 
problem after upgrading to WindowsXP. When I was using Windows Professional 
2000, I did not have this problem. Also, the autocomplete feature occurs before 
the request hits the proxy.

Comment 8

14 years ago
Let's get all the basic info:

What exactly do you type, and what does the URL become?

(If it doesn't go to www.localhost.net.au, then this is not Internet Keywords).

What happens if you turn proxy off?

(If you have proxy logs, they will show what requests are sent to your proxy).

What happens in mozilla?

(based on what you are describing, this is probably going to be a firebird-only
problem).

What happens if you disable IK and DG?

   http://www.mozilla.org/docs/end-user/internet-keywords.html
   http://www.mozilla.org/docs/end-user/domain-guessing.html

You can find instructions on manually disabling the two trunk-based features
that Firebird inherits. That would isolate firebird behavior to firebird code.
(Reporter)

Comment 9

14 years ago
1. Condition one (not using proxy):
   A. I type http://localhost:8888/myapp
   B. No URL changes occur in the address bar
   C. If my container is running, I get the app
   D. If my conainer is not running, I get "The connection was refused when 
attempting to access http://localhost:8888."

2. Condition two (using proxy):
   A. I type http://localhost:8888/myapp
   B. URL immediately changes to http://www.localhost.com, regardless of 
whether or not my container is running or not
   C. Browser attempts to connect to http://www.locahost.com, regardless of 
whether or not my container is running or not
   D. Browser stalls indefinitely
   E. Browser will only connect to valid URLs and will not connect to any non-
proxied addresses I have added to the "don't proxy" list.

3. The proxy logs show my browser tying to access 
http://www.localhost.com/myapp and that the communication failed.


Again, this behavior has only occurred since upgrading my OS from MS Windows 
2000 to XP.

I tried removing all items from the "don't proxy" list, and the results are the 
same.

I will try using Mozilla and see if I get different results, and will add those 
results here.
(Reporter)

Comment 10

14 years ago
After running the test with Mozilla vs. Firebird, I can confirm that the 
condition described in this bug only occurs in Firebird.

Comment 11

14 years ago
Reading bug 31510 comment 2, this appears to be expected behavior; localhost is 
by default on the "no proxies for" list.

Reporter; what happens if you set network.proxy.no_proxies_on to a zero-length 
string?

via UI, do
1. Tools->Options->General->ConnectionSettings...
2. select Manual Proxy Settings checkbox
3. clear the "No Proxy For:" textbox.

Comment 12

14 years ago
Actually, a better question is "What is your No Proxies For set to?"  I realize 
this just happened after your upgrade, but it sounds exactly like the problem 
I've seen before with proxies + localhost.
(Reporter)

Comment 13

14 years ago
Patrick,

Here are the results, which are very interesting. I had selected to use the 
proxy and as you suggested, tried using no "do not proxy" addresses. I got the 
same results, that is, the browser (Firebird) tried to resolve to 
www.localhost.com. 

The interesting part came when I deceided to try a couple of different things. 
I tried various combinations of localhost, no localhost, etc in the "do not 
proxy these addresses" field. I tried no addresses, etc. All with the same 
results. Until....I tried localhost alone as the only address in that field. 
Then the browser behaved as expected. It did not proxy localhost, it did not 
try to autocomplete to www.localhost.com and it did proxy then any other 
addresses.

Hope that helps, weird results.

Comment 14

14 years ago
I have tested this and found that if you put your no-proxy settings with a
leading http:// it seems to work with multiple entries, while (for me) just
having "localhost" in there still doesn't work.

Mine says:
"http://localhost, http://127.0.0.1"

Please test and reply with results.
(Reporter)

Comment 15

14 years ago
I tried several different combinations, using http://whatever did not work for 
me. What did end up working (it works!!!) is making sure I put a space after 
each comma. Weird. Anyway, using the following pattern I am able to have my 
cake and eat it too: localhost, 127.0.0.1, local_site, local_site
Scott, now that you got it to work, do you still consider this a bug?
(Reporter)

Comment 17

14 years ago
Simon, no this would no longer be a bug, although I would make sure this gets 
in the documentation. Thanks, Scott - P.S. Awesome browser!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Thanks for replying, Scott. But only bugs which can be pointed to a checkin
should be marked FIXED. The rest should be marked WORKSFORME.

See also http://www.mozilla.org/quality/help/bugzilla-privilege-guide.html
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 20

14 years ago
(is this the correct description of the problem?)
Summary: localhost autocompletes to www.localhost.com when using proxy with XP → no proxy: requires spaces between items

Comment 21

14 years ago
V: WFM.
looking at the code, the space should not be required.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.