Closed Bug 232544 Opened 21 years ago Closed 21 years ago

Input expand/collapse buttons don't work after ctrl+up/down

Categories

(Other Applications :: ChatZilla, defect)

x86
Windows 2000
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neil, Assigned: bugzilla-mozilla-20000923)

Details

Attachments

(1 file)

Steps to reproduce problem:
1. Click the expand button
2. Press ctrl+down
3. Click the expand button
4. Press ctrl+up
5. Click the collapse button
6. Press ctrl+up
7. Click the collapse button
Steps 3 and 7 do not work as you expect them to.
Also when they do work the buttons seem to be much slower than the ctrl arrows.
Taking.
Assignee: rginda → silver
This appears to simply be the buttons using the pref for multiline mode (which
updates the box to the new mode) and the Ctrl shortcuts are directly updating
the box. Patch soon.
Status: NEW → ASSIGNED
Attachment #140278 - Flags: review?(samuel)
Attachment #140278 - Flags: review?(samuel) → review+
Comment on attachment 140278 [details] [diff] [review]
Dispatches a call to change the pref, rather than directly updating state.

Checked in.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Ah, so the reason that the buttons were slower was that they went though the
event loop, while the keys just stomped on the state directly, and the keys are
now just as slow as the buttons :-/
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: