Closed Bug 232545 Opened 16 years ago Closed 16 years ago

Text included by <marquee></marquee> is not shown

Categories

(Core :: XBL, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: KKuhlemann, Assigned: neil)

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040128 Firebird/0.8.0+

On websites using scrolling text by the <marquee>-tag, thw text inside of
<marquee></marquee> is not shown. This is only in 1.7a (firebird) about since
2004-01-15 nightly.
In Mozilla 1.6 works the scrolltext, even in firebird pre0.8 nighlies. 
Even old Netscape 4.x showed this text without scrolling, latest firebird shows
nothing at all.

Reproducible: Always
Steps to Reproduce:
1.Open a website with a <marquee>-scrolltext.
2.The text inside the <marquee></marquee> tags is not shown.
3.

Actual Results:  
Firebird failed to show the marquee-scrolling and don't show the text at all.

Expected Results:  
Performing the marquee-scrolling as Mozilla 1.6 does.
Agreed. There are other bugs that stop marquees being rendered in both Seamonkey
and Firebird (e.g. bug 208683) in certain situations, but this one seems to be
Firebird-specific (I'm using 20040120 Firebird/0.7+).

I'll attach a very simple text case to demonstrate.
Attached file Very simple marquee
Open the attachment in both Firebird and Seamonkey and compare. The marquee
fails to function in recent builds of the former.
Bug also present in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040118

->Browser - Layout: View Rendering
Component: General → Layout: View Rendering
Product: Firebird → Browser
Version: unspecified → Trunk
confirmed also on 2004013105/Mac.
regression.
marking New.
Assignee: blake → roc
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
QA Contact: ian
Hardware: PC → All
Please don't confirm bugs that are pretty clearly in the wrong component.... 
Just opening the JS console would have told you this is NOT a layout error.

This works in build 2004-01-10-09 and is broken in build 2004-01-11-09.

Backing out the XBL sink changes from bug 229526 fixes this problem.
Assignee: roc → hyatt
Component: Layout: View Rendering → XBL
The problem, of course, is that we are looking at
ocument.getAnonymousNodes(this)[0].firstChild.firstChild where the markup is:

283     <content>
284       <html:div xbl:inherits="" style="overflow: -moz-scrollbars-none">
285         <xul:hbox style="margin: 0 100%;">
286           <html:div>
287             <children/>
288           </html:div>
289         </xul:hbox>
290       </html:div>
291     </content>

The [0] thing is the outermost <html:div> since whitespace inside <content> _is_
stripped.  Its firstChild, however, is no longer the <xul:hbox> but the textnode
that we are no longer stripping from it.  And the textnode's firstChild is
undefined, of course (instead of being the inner <html:div>).

Fixing this up is easy-ish, but I wonder how much other XBL that does similar
things got broken by the change in bug 229526...
Assignee: hyatt → neil.parkwaycc.co.uk
Severity: normal → major
Flags: blocking1.7a?
Attached patch Proposed patchSplinter Review
Attachment #140495 - Flags: review?(doronr)
Comment on attachment 140495 [details] [diff] [review]
Proposed patch

Are such changes announced anywhere before they land?
Attachment #140495 - Flags: review?(doronr) → review+
Comment on attachment 140495 [details] [diff] [review]
Proposed patch

sr=bzbarsky, and please try to lxr for patterns that may have been broken by
the other patch, ok?
Attachment #140495 - Flags: superreview+
Fix checked in.

A brief scan of LXR shows 5 classes of xml files that use the html namespace.
1) tests (don't use xbl)
2) obsolete (don't use xbl)
3) pretty print (does not appear to be affected)
4) textbox multiline="true" (already fixed)
5) this bug

So, hopefully, there isn't anything left to fix.
So can this be marked fixed?
Flags: blocking1.7a?
Whoops, did I forget to select the knob :-(
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
The notorious marquees work fine, once again :) 20040204 Firebird/0.8.0+
You need to log in before you can comment on or make changes to this bug.