Can't download any file via right mouse click -> "Save Link To Disk" using squid proxy

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
--
major
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Artem S. Tashkinov, Assigned: Darin Fisher)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040128 Firebird/0.8.0+

I installed latest Firebird with new configuration and then I can't save any
file via pop-up menu.

Reproducible: Always
Steps to Reproduce:
1. Choose any link and right click mouse on it
2. Choose Save Like To Disk
3.

Actual Results:  
An error message saying "The link could not be saved. The web page might have
been removed or had its name changed"

Expected Results:  
Starting a download

This bug was discussed almost hald a year ago and someone even proposed a patch
and the patch had been commited into main FireBird tree. The strangest thing is
that this bug now reappeared though all xpi's seem to be OK.

Comment 1

14 years ago
Similar to bug 232650, filed with a build from the same day (but a different
branch).

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040302 Firefox/0.8

I don't even get the error, clicking 'save link to disk' is ignored.

Comment 3

14 years ago
In Firefox 08, I can save files to disk - however, a spurious .html tag is added
to the filename. For example, I downloaded a file called test.mid (MIDI file)
from Save Link to Disk (Context Menu), and the file downloaded correctly, but
was called test.mid.html. Removing the .html allowed the file to be played normally.

Comment 4

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040402
Firefox/0.8.0+

Geoff: that's a different bug.

Comment 5

14 years ago
I have this firefox build: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a)
Gecko/20040418 Firefox/0.8.0+

When I right click and press save as (E.G. on an image file), the browser comes
up with a "download error" window. I press the OK button and then it pops up
again! I couldn't stop it from popping up all the time so I had to kill firefox.
And the file does not download to my computer. 

Comment 6

14 years ago
cool_otter@yahoo.com: that's bug 240367.

Comment 7

14 years ago
WFM.  If you still see this bug with a nightly from April 24 or later, reopen
and give an example of a site you see it on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040425
Firefox/0.8.0+

Being on this page http://www.mozilla.org/products/firefox/ I right click save
as on the “...nothing short of a revelatory experience.” URL
then
my proxy server generates 1082961165.367    269 192.168.0.15 TCP_DENIED/403 301
HEAD http://www.mozillazine.org/talkback.html? - NONE/- text/html

tethereal dump:
192.168.0.15 -> 192.168.0.99 HTTP HEAD
http://www.mozillazine.org/talkback.html?article=4145
192.168.0.99 -> 192.168.0.15 TCP 3128 > 1567 [ACK] Seq=2981817352 Ack=2047459
192.168.0.99 -> 192.168.0.15 HTTP HTTP/1.0 403 Forbidden
192.168.0.15 -> 192.168.0.99 TCP 1567 > 3128 [ACK] Seq=2047459287 Ack=2981817
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

14 years ago
Internet Explorer works fine and generates very diffenent output in 
squid log:
1082962012.857   1660 192.168.0.15 TCP_MISS/200 9411 GET
http://www.mozillazine.org/talkback.html? - DIRECT/207.44.238.27 text/html

tethereal:
0.000000 192.168.0.15 -> 192.168.0.99 HTTP GET
http://www.mozillazine.org/talkback.html?article=4145 HTTP/1.1
  0.000036 192.168.0.99 -> 192.168.0.15 TCP 3128 > 1593 [ACK] Seq=4019561518
Ack=2276186770 Win=7504 Len=0
  0.511999 192.168.0.99 -> 192.168.0.15 HTTP HTTP/1.0 200 OK
  0.512012 192.168.0.99 -> 192.168.0.15 HTTP Continuation
  0.513546 192.168.0.15 -> 192.168.0.99 TCP 1593 > 3128 [ACK] Seq=2276186770
Ack=4019563011 Win=17520 Len=0
  0.527649 192.168.0.99 -> 192.168.0.15 HTTP Continuation
  0.719955 192.168.0.15 -> 192.168.0.99 TCP 1593 > 3128 [ACK] Seq=2276186770
Ack=4019564459 Win=16072 Len=0
  0.737339 192.168.0.99 -> 192.168.0.15 HTTP Continuation
  0.753222 192.168.0.99 -> 192.168.0.15 HTTP Continuation
  0.754687 192.168.0.15 -> 192.168.0.99 TCP 1593 > 3128 [ACK] Seq=2276186770
Ack=4019567355 Win=17520 Len=0
  0.769117 192.168.0.99 -> 192.168.0.15 HTTP Continuation
  0.785016 192.168.0.99 -> 192.168.0.15 HTTP Continuation
  0.786484 192.168.0.15 -> 192.168.0.99 TCP 1593 > 3128 [ACK] Seq=2276186770
Ack=4019570251 Win=17520 Len=0
  0.792220 192.168.0.99 -> 192.168.0.15 HTTP Continuation
  0.792384 192.168.0.99 -> 192.168.0.15 TCP 3128 > 1593 [FIN, ACK]
Seq=4019570929 Ack=2276186770 Win=7504 Len=0
  0.793100 192.168.0.15 -> 192.168.0.99 TCP 1593 > 3128 [ACK] Seq=2276186770
Ack=4019570930 Win=16842 Len=0
(Reporter)

Comment 10

14 years ago
Sorry for so many comments but the problem remains on any URL/site.

Comment 11

14 years ago
> Being on this page http://www.mozilla.org/products/firefox/ I right click save
> as on the “...nothing short of a revelatory experience.” URL

WFM on that page.  I'll let someone else try to understand the logs you pasted.

Does this problem also happen with Seamonkey?
(Reporter)

Comment 12

14 years ago
SeaMonkey 1.7 rc1 identifies itself as 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

and the bug <b>remains</b>
(Reporter)

Comment 13

14 years ago
I think the product should be changed from Firefox to general Mozilla because
this bug exists both in Mozilla Seamonkey and Mozilla Firefox. Also the severity
of the bug is to be changed to critical (and regression at the same time)
because Mozilla 1.5 and Firefox 0.5 worked OK if I ain't mistaken
(Reporter)

Comment 14

14 years ago
All my latter quotes starting from #8 are related to bug N237989
http://bugzilla.mozilla.org/show_bug.cgi?id=237989 . I think these bugs should
be merged

Comment 15

14 years ago
*** Bug 237989 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
-> Browser, Networking: HTTP
Keywords: regression

Updated

14 years ago
Component: General → Networking: HTTP
Product: Firefox → Browser
Version: unspecified → Trunk

Updated

14 years ago
Assignee: firefox → darin
QA Contact: core.networking.http

Comment 17

14 years ago
The problem is that the proxy server is saying that we can't access the address
in question when we send the HEAD request.  This causes Mozilla to give up
saving the  file.
Are you blocking the use of the HEAD request?  I found you can setup acls for
diffrent HTTP request using the command `acl aclname method method-type` in
squid.conf.  I know little about squid configuration.
Summary: Can't download any file via right mouse click -> "Save Link To Disk" → Can't download any file via right mouse click -> "Save Link To Disk" using squid proxy
(Reporter)

Comment 18

14 years ago
Finally I understood it's not a Mozilla bug but a misconfiguration of Squid
proxy server.
My server had this ACL:

acl getpost method GET POST

thus allowing only GET and POST methods for connection. After I manually changed
this ACL to:

acl getpost method GET POST HEAD

everything worked just fine. I think this issue should be traced somewhere in
Mozilla help section. As for Internet Explorer first of all it tries to start
saving the requested document in the disk cache (using GET) at the same time
showing "Save as" dialog. So IE can certainly work even if HEAD method is not
allowed and Mozilla can't.

I leave this bug "UNCOMFIRMED" so that other developers take this issue into
consideration and update Mozilla's help accordingly.

Comment 19

14 years ago

*** This bug has been marked as a duplicate of 160454 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Don't mark bugs dup of bug 160454, please.
Status: RESOLVED → UNCONFIRMED
Depends on: 160454
Resolution: DUPLICATE → ---
Marking WORKSFORME.
If this bug is still visible with a Mozilla (not Firefox) build later than
2004-10-10 (when bug 160454 was fixed), then please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.