Closed Bug 232688 Opened 21 years ago Closed 19 years ago

Pastes in body of reply when 'middle-click' on the scroll bar

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 70698

People

(Reporter: kevin, Assigned: mscott)

Details

User-Agent:       
Build Identifier: Mozilla Thunderbird 0.4 (20031205)

Scenario: 
Replying to a message.
The reply automatically focuses to the bottom of the previous message in the 
input area. To get to the top of the message, click in the right scroll bar with 
a single left mouse click. If there is text saved in the mouse buffer from 
highlighting text in any application (browser, shell, email), the buffer will 
automatically be pasted at the very top of the reply, right next to the quoted 
inline text. Since it is unexpected, you may have mail recipients wondering why 
strings of text are right below your intended reply.

Reproducible: Always
Steps to Reproduce:
1. Highlight text in any application so it is saved to buffer
2. Open Thunderbird and reply to any message
3. Click in right scroll bar once with left mouse button
4. Notice buffered text pasted next to the quoted original message

Actual Results:  
Buffer is pasted at the top of the message reply

Expected Results:  
There should be NO evacuation of the buffer- apparently the message window and 
the scroll bar area are one and the same when responding to a mouse action.

I would almost classify this as MAJOR, only for the fact that sometimes you 
might have information in the buffer that is sensitive in nature and pasting it 
without realizing it could cause problems with the people who read what is 
mistakenly put in the message
Damn- my reporting error, I said this was the LEFT mouse click and that is of
course, false. The MIDDLE mouse click in the scroll area will do this.

I know that a middle mouse click expends the buffer/copied text to an editable
area. But since this is happening when middle-clicking on a scroll bar, I would
think it wouldnt do that.

I often use a middle click for browser scroll bars. I guess I should learn to
not do that, but it's tough to unlearn since I have been doing it for almost 10
years now. :-)
Severity: normal → minor
Summary: Buffer automatically pastes in reply when 'clicking' the scroll bar → Pastes in body of reply when 'middle-click' on the scroll bar
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

*** This bug has been marked as a duplicate of 70698 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.