Visiting http://www.prosoft-ky.com/ crashes mozilla with X11 Badlength error

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Dave Morse, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040121

When I go to http://www.prosoft-ky.com/ my browser either hangs or disappears. 
usually disappears.  The console has this to say:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 51038 error_code 16 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Reproducible: Always
Steps to Reproduce:
1. visit web site
2. crash and burn

Actual Results:  
guess.

Expected Results:  
not crash.

I am useing the default theme.
My OS is Debian 3.0 with the gnome 2 backport.

Comment 1

14 years ago
WFM Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7a) Gecko/20040129
Reporter, are you able to reproduce this with a current nightly build of Mozilla?
-> http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest/
(but... be careful with nightlies ;)
Keywords: crash

Comment 2

14 years ago
worksforme with linux trunk 20040130 and gtk2/xft CVS.

make sure all your fonts are world-readable (I think that fix made it into 1.6,
but I'm not sure).

can you start Mozilla with --sync, attach gdb, visit the page to make Mozilla
crash and grab a stack from gdb?
Blocks: 198955
Or .fon files based on the typeface.

Comment 4

14 years ago
WFM / mozilla-1.6-5mdk

Comment 5

14 years ago
Well, as no one seems to be able to reproduce this (I also asked on BugDay today)
I mark this WFM.
Cry out loud if your opinion is different.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.