Closed Bug 232707 Opened 19 years ago Closed 19 years ago

Right-click context menu for toolbar bookmarks broken after customizing navigation toolbar icons

Categories

(Firefox :: Bookmarks & History, defect, P2)

x86
All
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: skirge01, Assigned: vlad)

References

Details

(Keywords: fixed-aviary1.0)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040130 Firebird/0.8.0+

After opening the customize navigation toolbar window, regardless of whether
changes are made, the right-click context menu for deleting bookmarks from the
bookmarks toolbar no longer deletes the bookmark.

Reproducible: Always
Steps to Reproduce:
1.  Right-click navigation toolbar.
2.  Select 'customize'.
3.  Click 'done'.
4.  Right-click any bookmark on the bookmark toolbar.
5.  Select 'delete'.

Actual Results:  
Context menu will disappear and/or close any open bookmark toolbar menu.  The
bookmark is still there, though.

Expected Results:  
Bookmark should have been deleted.

I have verified this on the branch build mentioned above as well as the branch
build from 01/28.  Each build is installed on a completely separate computer,
with one running Windows 2000 Professional and the other running Windows XP.

Windows 2000 build:  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040128 Firebird/0.7+

Windows XP build:  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040130 Firebird/0.8.0+

Both systems produce the same results.  Closing Firebird and restarting causes
the functionality to work again.
Confirming with Gecko/20040128 Firebird/0.7+, Windows XP.
(In reply to comment #0)
> Windows 2000 build:  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
> Gecko/20040128 Firebird/0.7+
> 
> Windows XP build:  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
> Gecko/20040130 Firebird/0.8.0+

Obviously, I reversed the builds running on each system.  NT5.0 is clearly the
Windows 2000 box and NT5.1 is the XP box.  It should read:

Windows XP build:  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040128 Firebird/0.7+

Windows 2000 build:  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040130 Firebird/0.8.0+

Sorry for any confusion.
Confirming, using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040130
Firebird/0.8.0+

Also note that delete is not the only functionality that becomes unavailable,
the entire context menu no longer works (ie. properties, open in new tab, open
etc.. all don't work).

Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 204599 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
I cannot reproduce
[url=http://bugzilla.mozilla.org/show_bug.cgi?id=204599]bug#204599[/url] on this
build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040128 Firebird/0.7+

Therefore, I do not believe they are the same and am re-opening this one.  I
posted similar comments on bug#204599.

Also confirming Ashley's comment about the entire context menu not working after
customizing the navigation toolbar.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
As per comment #5, and my own reproducing this bug, it is not a dupe of 204599
(since people who experience this bug can't reproduce that bug), although the
symptoms seem to be the same.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040128 Firebird/0.8.0+

OS: Windows 2000 → All
*** Bug 223399 has been marked as a duplicate of this bug. ***
Confirmed: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8
I'm seeing the same thing, with a strange complication: On some bookmark
folders, I cannot get the right-click menu to do anything, without having to
customize the toolbar, and also not after restarting Firefox. In other folders,
the menu gets non-functional by customizing the toolbar, and works after restarting.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040216
Firefox/0.8.0+
This sounds similar to the bookmark toolbar wierness in bug 221482, which is
related to customising toolbars too.
Flags: blocking1.0?
Flags: blocking1.0? → blocking1.0+
*** Bug 244395 has been marked as a duplicate of this bug. ***
Sounds similar to this problem 

View --> Toolbars --> Customize
Drag the create new tab icon over to the left of the back arrow on the URL Toolbar
Click Done
The File Edit View etc menus are greyed out.

Restarting Firefox clears the immediate problem.  

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040528
Firefox/0.8.0+
Nominating blocking 0.9 since this is a very obvious bug.
Flags: blocking0.9?
the fix is certainly not obvious, or it'd be fixed by now.  It has a simple
workaround (restart the browser) and that'll have to do for 0.9
Flags: blocking0.9? → blocking0.9-
*** Bug 246408 has been marked as a duplicate of this bug. ***
*** Bug 247033 has been marked as a duplicate of this bug. ***
The fix for bug 221482 seems to fix this issue as well; I can't reproduce it in
my local build with the 221482 patches applied.  I'm guessing the bookmarks
folder's ref attribute not being set is affecting this.
Assignee: p_ch → bugs
Status: REOPENED → NEW
Assignee: bugs → vladimir
Flags: blocking-aviary1.0RC1?
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707
Firefox/0.9.0+
But I can repro on the trunk with Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.8a2) Gecko/20040707 Firefox/0.8.0+
I can also confirm that this is fixed on the branch.
*** Bug 250022 has been marked as a duplicate of this bug. ***
*** Bug 250660 has been marked as a duplicate of this bug. ***
Marking fixed, patch is in on branch (trunk also once freeze ends, I assume).
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
*** Bug 248813 has been marked as a duplicate of this bug. ***
(In reply to comment #24)
> Marking fixed, patch is in on branch (trunk also once freeze ends, I assume).

This hasn't shown up on the trunk as of the 20040720 build.
*** Bug 252723 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.0PR?
Keywords: fixed-aviary1.0
Same problem with version 1.0.3 of Firefox.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.