Use of hover generated content in links causes them to flash on mouseover

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
P3
normal
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Sekundes, Assigned: roc)

Tracking

({perf, regression, testcase})

Trunk
perf, regression, testcase
Points:
---
Bug Flags:
blocking1.7 -
blocking1.8a2 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040130 Firebird/0.8.0+

This page has slow hover effect on the right floated sidebar in Mozilla 1.6 and
the latest build.
I doubted it's due to the CSS font-family: "Bitstream Vera Sans", Arial, Tahoma,
sans-serif; in "body" selector of http://www.virtuelvis.com/styles/screen.css.

And the hover effect would flash in the latest build(20040128 and 20040130) I tried.
It seems due to the CSS content: "\25B9\00A0"; in "div.sidebar > ul li a:before"
selector of http://www.virtuelvis.com/styles/screen.css.

I can't make a simple testcase as it seems as fast as normal. And it's flashed
too quickly to see.

Reproducible: Always
Steps to Reproduce:
1.go to http://virtuelvis.com/.
2.move the mouse over the right floated sidebar.
3.move it around.
Actual Results:  
slow hover effect
and flashes(seems Mozilla 1.7a only, Mozilla 1.6 does not flash).
Keywords: qawanted

Updated

14 years ago
Keywords: perf
(Reporter)

Comment 1

14 years ago
I also got flash effect at header of the page http://phoenity.com/newtedge/ .
(Reporter)

Comment 2

14 years ago
Note to myself: same flash effect in the sidebar of
http://literarymoose.info/=/css.xhtml.
(Reporter)

Updated

14 years ago
Blocks: 230665
(Reporter)

Comment 3

14 years ago
floated flashed layer is shown on the left while moving the mouse hover the
sidebar items at this page, http://www.virtuelvis.com/archives/159.html.
(Reporter)

Comment 4

14 years ago
All comments except comment 3 are for Mozilla 1.7a(20040219) only.
comment 3 can be produced in Mozilla 1.6 and Mozilla 1.7a(20040219).
(Reporter)

Updated

14 years ago
Component: Browser-General → Layout

Comment 5

14 years ago
Confirmed on Windows XP nightly build 20040219.  Can someone set this bug to
confirmed status?

Comment 6

14 years ago
Created attachment 141931 [details]
Testcase for flashing links

This testcase illustrates how links using hover:after flash in the Mozilla
nightlies, post 1.6 (unsure when it first started)

Comment 7

14 years ago
Comment on attachment 141931 [details]
Testcase for flashing links

A small note, I've used black backgrounds because I found they the flashing
easier to see.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted → regression, testcase
Summary: overall slow performance and flash hover effect on specific page → Use of hover:after on links causes them to flash on mouseover

Updated

14 years ago
Summary: Use of hover:after on links causes them to flash on mouseover → Use of hover:after in links causes them to flash on mouseover

Comment 8

14 years ago
Regressed between a 01/08 build and a 01/10 build.

Comment 9

14 years ago
Guessing component, -> View Rendering
Component: Layout → Layout: View Rendering

Updated

14 years ago
Assignee: general → roc
QA Contact: general → ian
Priority: -- → P2
I can't reproduce in Linux/GTK2 with a trunk build. Could this be Windows only?

Comment 11

14 years ago
I'm seeing this test case do what it claims on the following build:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040312 Firefox/0.8.0+

Also updating summary at request of reporter.

--> All/All
OS: Windows 2000 → All
Hardware: PC → All
Summary: Use of hover:after in links causes them to flash on mouseover → Use of hover generated content in links causes them to flash on mouseover
I think comment #3 is a different bug. I see that problem, but I don't see any
problem on the other pages.
(Reporter)

Comment 13

14 years ago
testcase for #3
data:text/html;charset=utf-8,%3Cstyle%3E%0D%0A.right%20%7B%0D%0A%20%20float%3A%20right%3B%0D%0A%20%20overflow%3A%20auto%3B%0D%0A%7D%0D%0Aa%3Ahover%3Abefore%2C%20a%3Ahover%3Aafter%20%7B%0D%0A%20%20content%3A%20%22!%22%3B%0D%0A%7D%0D%0A%3C%2Fstyle%3E%0D%0A%3Cdiv%3EThis%20line%20is%20necessary%20to%20be%20included%20for%20the%20testcase.%3C%2Fdiv%3E%0D%0A%3Cdiv%20class%3D%22right%22%3ELet's%20see...%3C%2Fdiv%3E%0D%0A%3Ca%3EMove%20your%20mouse%20here%3C%2Fa%3E

It's also somewhat related to hover generated content, but with float and
overflow too.
If it's different bug, please separate it for me, thanks.
(Reporter)

Comment 14

14 years ago
re #12:
yes, It can been seen on that page only as the pre has overflow property with
the div wrapped that has float property.

more apparent testcase.
But you still have to hover the mouse a few times to see this effect.
data:text/html;charset=utf-8,%3Cstyle%3E%0D%0A.left%20%7B%0D%0A%20%20float%3A%20left%3B%0D%0A%7D%0D%0A.right%20%7B%0D%0A%20%20float%3A%20right%3B%0D%0A%7D%0D%0A.box%20%7B%0D%0A%20%20background%3A%20black%3B%0D%0A%20%20color%3A%20white%3B%0D%0A%20%20overflow%3A%20auto%3B%0D%0A%7D%0D%0Aa%3Ahover%3Abefore%2C%20a%3Ahover%3Aafter%20%7B%0D%0A%20%20content%3A%20%22GC%20used%22%3B%0D%0A%20%20background%3A%20red%3B%0D%0A%7D%0D%0A%3C%2Fstyle%3E%0D%0A%3Cdiv%3EThis%20line%20is%20necessary%20to%20be%20included%20for%20the%20testcase.%3C%2Fdiv%3E%0D%0A%3Cdiv%20class%3D%22right%20box%22%3ELet's%20see...%3C%2Fdiv%3E%0D%0A%3Cdiv%20class%3D%22left%20box%22%3ELet's%20see...%3C%2Fdiv%3E%0D%0A%3Ca%3EMove%20your%20mouse%20here%3C%2Fa%3E

ignore the previous one I provided.
that's hard to see.
(Reporter)

Updated

14 years ago
Flags: blocking1.7?
Depends on: 224426
Priority: P2 → P3
Depends on: 238493
No longer depends on: 224426
(Reporter)

Comment 15

14 years ago
comment #3 seems to be bug 228059.
(Reporter)

Updated

14 years ago
No longer blocks: 230665
(Reporter)

Comment 16

14 years ago
yes, comment #3 is bug 228059, which is dupe of bug 132337.

Updated

14 years ago
Flags: blocking1.7? → blocking1.7-
(Reporter)

Updated

14 years ago
Flags: blocking1.8a2?

Updated

14 years ago
Flags: blocking1.8a2? → blocking1.8a2-
(Reporter)

Updated

13 years ago
Flags: blocking1.8a3?
(Reporter)

Comment 17

13 years ago
It's WFM on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a3)
Gecko/20040717.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Flags: blocking1.8a3?
You need to log in before you can comment on or make changes to this bug.