bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

l10n is not possible for Preference panes titles

RESOLVED FIXED in Camino0.8

Status

Camino Graveyard
Preferences
--
trivial
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: Marcello Testi, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino0.8
PowerPC
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X

The preference panes titles (the ones that appear along with the prefpane icons)
reside in the
[Path_to_Camino.app]/Contents/PreferencePanes/[Name_of_PP].prefPane/Contents/info.plist
file.
To allow l10n, they should reside in a .nib or a .strings file inside a
English.lproj folder

Reproducible: Always
Steps to Reproduce:
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Camino0.8

Comment 1

15 years ago
Perhaps it's best to shift this bug to the .9 list since Josh want's to do the
preference rewrite then? He could do this at the same time.
(Assignee)

Comment 2

15 years ago
if this is a l10n blocker, we should fix it beforehand.
(Assignee)

Comment 3

14 years ago
to localize, set "PreferencePanelLabel" in localized.strings for each pref
panel. if one isn't present, just create one with this string in it.

landed on branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> to localize, set "PreferencePanelLabel" in localized.strings for each pref
> panel. if one isn't present, just create one with this string in it.

Good, thanks. Now, woud it be possible to have the files and the strings already
in the Camino package (in the English.lproj folder)?
This way, who uses automated strings extraction tools like AppleGlot or nibtool
doesn't need to manually add the files every time l10n is updated.

Comment 5

14 years ago
Yes, Could developers create a sample string lines for the 5 panes?

I cannot find Localized.string file in the Content/Resources folder.  Is it
Localizable.string file?

Thanks!
(Assignee)

Comment 6

14 years ago
do what i mean, not what i say ;) yes, localizable.strings.

Comment 7

14 years ago
Mr. Pinkerton,

I really don't know what to add to the Localizable.string file. Could you tell
me the proper terms to add?  I.e., what is the term for "Navigation" Pane?  I
have tried to add

"Navigation" = "[Translated]";

but it didn't work.

Thanks you!
(Assignee)

Comment 8

14 years ago
"PreferencePanelLabel" = "Translated"

as per comment #3

Comment 9

14 years ago
Sorry, Mr. Pinkerton, I must be very very dumb.  I still can't get it work.

In file "Localizable.string" of "zh_TW.lproj" folder, I have tried to add
"Navigation", "NavigationLabel" and "NavigationPaneLabel" one at a time. None of
them works.  The lable for "Navigation" pane is still unchanged and showing
"Navigation"!

Could you set an example line for the "Navigation" label?  Or I need a separate
line, "PreferencePaneLabel" before them?

I am totally lost.  Please help.
(Assignee)

Comment 10

14 years ago
"PreferencePanelLabel" = "Navigation"

that's the sample for English. translate accordingtly.

Comment 11

14 years ago
Mr. Pinkerton, sorry to bother you again.

I have added the following lines into Localizable.strings:

"PreferencePanelLabel" = "滑網";
"PreferencePanelLabel" = "外觀";
"PreferencePanelLabel" = "網頁功能";
"PreferencePanelLabel" = "私隱";
"PreferencePanelLabel" = "安全性";

Unfortuantely, the lables in the preference pane have not changed!  It still
shows "Navagtion", "Appearance", Web Features", "Privacy" and "Security".

I have changed the system language preference in International prefpane. 
Everything else looks fine.  These five preference pane labels are the only
untranslated string in the visible UI.

Due to the fact that this web page is encoded in ISO Latin 1, you may not read
the translate strings properly.  I posted this message as UTF-8.  You may view
them properly after switched to UTF-8 encoding.
(Assignee)

Comment 12

14 years ago
you need to put a single line in the localizable.strings for each individual
pref pane's package, not just in one central location.

Comment 13

14 years ago
Thanks for Mr. Pinkerton's patient.  I have finally gotten it works now.

By the way, I have noticed a few things:

1. In the RegionNames.strings of Appearance.prefPane, "vietnam" is missing from
the language/encoding option.

2. In the Appearance.nib of Appearance.prefPane, the 2 example strings, "(like 
Times)" and "(like Courier)", are too short for translated string in Traditional
Chinese and Simplified Chinese.  I have modified the Appearance.nib in the same
directory in order to show the complete strings.

3. In the [lang].lproj folder of Security.prefPane, it missed the
Localizable.strings file.  I have added one.

4. In the [lang].lproj folder of Web Features.prefPane, it missed the
Localizable.strings file as (3).  I have added one.

I would be really appreciated if the "PreferencePanelLabel" are added and helps
translators from adding them every time we run AppleGlot.

Again, a big thank you, Mr. Pinkerton!

Comment 14

14 years ago
Created attachment 150403 [details]
5 "Localizable.strings" files and a "RegionNames.strings" file

It contains 5 "Localizable.strings" files inside the 5 "English.lproj" folders
of prefpanes of Camino in their respectively location inside the "Camino.app". 
A line of '"PreferencePanelLabel" = "[Label]";' added to each of them.

Additionally, the "Localizable.strings" and "RegionNames.strings" inside
"Appearance.prefPane" are encoded in UTF-8 incorrectly.  They are converted to
UTF-16 for working correctly in AppleGlot.

The files are based on "2004/06/09-0.8" built downloaded from
ftp://ftp.mozilla.org/pub/mozilla.org/camino/nightly/2004-06-09-08-0.8/Camino.dmg.gz


Please get these changes into the CVS and help localiztion tranlators of Camino
project get the job done easier.

Comment 15

14 years ago
I fully understand that Pinkerton is under heavy work load and don't have the
time to modify/add "Localizable.strings" files in the prefpanes of Camino. 
Therefore I have created an archive of modified files for improving the
localization process.  

Please see the attachment and put the patched files back into CVS system.  That
would help us tranlators and save our half an hour for each of us everytime we
translate a new beta releases of Camino.

Thanks a lot!
(Reporter)

Comment 16

14 years ago
(In reply to comment #15)
> Please see the attachment and put the patched files back into CVS system.  That
> would help us tranlators and save our half an hour for each of us everytime we
> translate a new beta releases of Camino.

Janus, first thanks a lot  for pointing out this one I've been looking at for
some days but had not the time to  analyze.
I think we could gain better results if you open another bug with your
description and patch.

Don't forget to add the "l10n" string into the summary of the bug and please
insert myself as CC.
You need to log in before you can comment on or make changes to this bug.