Use repeatOverlay files to centralize repeat functionality of dialogs

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: wolfiR, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040201

the files content/repeatOverlay.* 
are missing in the jar.mn definition. Are they needed?
If yes please commit the attached patch. (If not, the files could be removed?)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 140407 [details] [diff] [review]
patch to add probably missing files
(Assignee)

Comment 2

14 years ago
Those files are there as the first step to centralize the "repeat" dialog UI.
They carry the "repeat" functionality that is currently being duplicated in
eventDialogs and todoDialogs. The goal is to eventually use them as overlays in
eventDialogs and todoDialogs and remove the redundant code from those dialogs.
So we can't add them to jar.mn because they aren't currently being used and we
don't want to remove them because we eventually have to use them. But I'll
change the summary so this doesn't fall through the cracks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: probably missing files in jar.mn → Use repeatOverlay files to centralize repeat functionality of dialogs

Comment 3

13 years ago
Files named repeatOverlay.* no longer exist
(http://lxr.mozilla.org/mozilla/search?string=repeatOverlay).

Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.