Don't display inline images when using a proxy

VERIFIED DUPLICATE of bug 205947

Status

Thunderbird
Mail Window Front End
VERIFIED DUPLICATE of bug 205947
15 years ago
14 years ago

People

(Reporter: Ferran Casarramona, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: ThunderBird 0.4 (20031205)

-I have Thunderbird configured to connect with a proxy
(tools/options/advanced/connection) but when I display a message with inline
images it don't display it, nor ask me for user_name/password.



Reproducible: Always
Steps to Reproduce:
1. Open ThunderBird configured for use a proxy that needs user_name/password.
2. Select a message with inline images.


Actual Results:  
The inline images are not shown.

Expected Results:  
It must ask for proxy user_name/password and then display inline images.

-If I right click on image and select "view image" a caption only windows open
and does nothing else.

Unexpected Workaround:
-However if I change "tools/options/general/window Configuration" to the left or
the middle option and press 'Ok' then Thunderbird ask me the user_name/password
and displays the inline images, and for any other message with image until
ThunderBird is relaunched.

Mozilla comparision:
- With Mozilla 1.5 a similar problem happens, but if you had accessed to the
proxy by FireBird or Mozilla itself the inline image are shown. This not happen
in Thunderbird.
(Reporter)

Comment 1

15 years ago
It is possible to workaround easily via "View/Layout/Wide View or Classic View"
(Reporter)

Comment 2

15 years ago
HTML code than don't ask for proxy's password:
<!-- |**|begin egp html banner|**| -->

<table border=0 cellspacing=0 cellpadding=2>
<tr bgcolor=#FFFFCC>
<td align=center><font size="-1" color=#003399><b>Yahoo! Groups
Sponsor</b></font></td>

</tr>
<tr bgcolor=#FFFFFF>
<td align=center width=470><table border=0 cellpadding=0 cellspacing=0> <tr> <td
align=center><font face=arial size=-2>ADVERTISEMENT</font><br><A
HREF="http://rd.yahoo.com/SIG=12crg6bbv/M=243273.4326031.5516772.1261774/D=egroupweb/S=1705082829:HM/EXP=1075386660/A=1750744/R=0/*http://servedby.advertising.com/click/site=552006/bnum=1075300260822271"
TARGET="_blank">
<IMG
SRC="http://servedby.advertising.com/site=552006/size=300250/bnum=1075300260822271/bins=1/rich=0"
WIDTH="300" HEIGHT="250" BORDER="0" ALT="Click to learn more...">
</A></td></tr></table></td>

</tr>
<tr><td><img alt="" width=1 height=1
src="http://us.adserver.yahoo.com/l?M=243273.4326031.5516772.1261774/D=egroupmail/S=:HM/A=1750744/rand=153821650"></td></tr>
</table>

<!-- |**|end egp html banner|**| -->
(Reporter)

Comment 3

15 years ago
HTML code than asks proxy's password:

<!-- |**|begin egp html banner|**| -->

<table border=0 cellspacing=0 cellpadding=2>
<tr bgcolor=#FFFFCC>
<td align=center><font size="-1" color=#003399><b>Yahoo! Groups
Sponsor</b></font></td>
</tr>

<tr bgcolor=#FFFFFF>
<td align=center width=470><table><tr><td align=center><font face=arial
size=-2>ADVERTISEMENT</font><br><IFRAME
SRC="http://ad.doubleclick.net/adi/N3349.yahoo1/B1282054.22;sz=300x250;code=18634;dcopt=rcl;click=http://rd.yahoo.com/SIG=12cs2k5jl/M=274551.4550177.5718621.1261774/D=egroupweb/S=1705082829:HM/EXP=1077097604/A=1994230/R=0/*;ord=1077011204954849?"
WIDTH=302 HEIGHT=252 MARGINWIDTH=0 MARGINHEIGHT=0 HSPACE=0 VSPACE=0
FRAMEBORDER=0 SCROLLING=no BORDERCOLOR='#000000'>
<SCRIPT language='JavaScript1.1'
SRC="http://ad.doubleclick.net/adj/N3349.yahoo1/B1282054.22;abr=!ie;sz=300x250;code=18634;dcopt=rcl;click=http://rd.yahoo.com/SIG=12cs2k5jl/M=274551.4550177.5718621.1261774/D=egroupweb/S=1705082829:HM/EXP=1077097604/A=1994230/R=1/*;ord=1077011204954849?">
</SCRIPT>
<NOSCRIPT>
<A
HREF="http://rd.yahoo.com/SIG=12cs2k5jl/M=274551.4550177.5718621.1261774/D=egroupweb/S=1705082829:HM/EXP=1077097604/A=1994230/R=2/*http://ad.doubleclick.net/jump/N3349.yahoo1/B1282054.22;abr=!ie4;abr=!ie5;sz=300x250;code=18634;dcopt=rcl;ord=1077011204954849?">
<IMG
SRC="http://ad.doubleclick.net/ad/N3349.yahoo1/B1282054.22;abr=!ie4;abr=!ie5;sz=300x250;code=18634;dcopt=rcl;ord=1077011204954849?"
BORDER=0 WIDTH=300 HEIGHT=250 ALT="Click Here">Click Here</A>
</NOSCRIPT>
</IFRAME></td></tr></table></td>

</tr>
<tr><td><img alt="" width=1 height=1
src="http://us.adserver.yahoo.com/l?M=274551.4550177.5718621.1261774/D=egroupweb/S=:HM/A=1994230/rand=417070609"></td></tr>
</table>

<!-- |**|end egp html banner|**| -->

Comment 4

15 years ago
Could this be a dupe of Bug 221772?

Comment 5

15 years ago
Dear Friens I have Mozilla Thunderbird 0.5 (20040207) running on a Pc witn Win
XP Pro Ver. 2002 SP 1

-I have Thunderbird configured to connect manually with a proxy
(tools/options/advanced/connection/manual connection to proxy) but when I
display a message with remote images it don't display them, nor ask me for
user_name/password.

Reproducible: Always
Steps to Reproduce:
1. Open ThunderBird configured in order to use a proxy that needs a
user_name/password.
2. Select a message with remote images.

Actual Results:  
The remote images are not shown.

Expected Results:  
It must ask for proxy user_name/password and then display remote images.

-If I right click on image and select "view image" a caption only windows open
and does nothing else.

Workaround (from bug 221772):
- If you reply to a mail that contains external elements like images,
Thunderbird asks for the proxy authentication and all the content of the mail is
displayed in the "reply-to" window. After this, all the mails you will access to
will be displayed entirely.

Mozilla comparision:
- With Mozilla 1.6 this problem does not happen: if you had accessed to the
proxy Mozilla itself the remote images are shown. This does not happen in
Thunderbird.

I do not know if this is a dupe of bug 221772, but certainly it is strictly
related to it: in my opinion it is a bug that compromise any serious effort to
struggle with MS OUTLOOK within a LAN with proxy.

I hope that in any future ver of TB there will be a full support to proxy: this
is a RFE and I do not agree with SEVERITY MINOR
(Reporter)

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 221772 ***
Severity: minor → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

14 years ago
REOPEN:
There are some weird workarounds, so when Thunderbird supports proxy auth, this
should be looked at carefully.
Status: RESOLVED → UNCONFIRMED
Depends on: 221772
Resolution: DUPLICATE → ---
Thunderbird supports proxy auth now with a checkin for bug 205947; what needs to
be looked at to resolve this one?

Comment 9

14 years ago
(In reply to comment #8)
> Thunderbird supports proxy auth now with a checkin for bug 205947;
> what needs to be looked at to resolve this one?

Reporter, is the problem still manifesting for you with current builds?  The 
patch from 205947 made it into 1.0.  If the problem no longer exists, please 
mark this as a dupe of that bug.
(Reporter)

Comment 10

14 years ago

*** This bug has been marked as a duplicate of 205947 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.