All email accounts must have unique pop3/imap server

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Michal Belda, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Maybe a bug, maybe a feature, but anyway - it's annoying. An email account must
have a unique pop3/imap server specified. If you have two emails (with different
signature and Reply-To) that are both sent to the same pop3 server you cannot
have them in mozilla email clients (both mozilla-mail and thunderbird) as
separate accounts.

Reproducible: Always
Steps to Reproduce:
1. Add one email account
2. Add account -> fill in name, email address ->
3. Fill in the same pop3 server as for the first email account or 
4. don't fill in anything
Actual Results:  
result of 3: A mail or newsgroup account with the same user name and server
already exists. Click back and enter a different server name

result of 4: Please enter a valid hostname

Expected Results:  
I don't know about 3., but there should exist a possibility to have an "empty"
email account, ie. account used only for sending email with its own signature
and Reply-To, but that doesn't have its own pop3/imap server.
(Assignee)

Comment 1

14 years ago
we have back end  support for multiple identities on the same account already.
Available on all platforms:

http://tumanov.com/entry/135

Comment 3

14 years ago
*** Bug 229868 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
I think only part of what this poster was talking about was multiple identities
(using his step 4). That's obviously been fixed.

I think the other part (using his step 3) is about having 2 accounts with a
single host. I have this with fastmail.fm and it works fine: foo@fastmail.fm,
bar@fastmail.fm -- both have the same IMAP server, just different usernames. WFM.

I don't know about POP though.

Comment 5

14 years ago
I set up Thunderbird on my wifes W2000 box last night and migrated settings etc. from 
Mozilla 1.5 email. Two of her accounts reside on the same POP3 server. Thunderbird 
created only one account directory for that server, the scond account pointed to the first 
account directory. In Mozilla there was a separate directory created for each account with a 
number appended to the server name eg. <server>-1. The inbox for the second account was 
not accessible. 
 
This made Thunderbird unusable for her and she reverted to Mozilla 

Comment 6

14 years ago
If I read the original report correctly then this bug looks like it might be a
duplicate of Bug 41929.

Comment 7

14 years ago
I'm marking this WFM, based on comments 1, 2 and my own account setup. Please
reopen if the problem still exists.

re comment 5 - Thunderbird defaults to a 'global' inbox, and I think that's the
situation you've got. Check Account Options->Server Settings->Advanced to see if
this is enabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.