screen.availWidth and screen.availHeight are not updated when you change screen resolution

VERIFIED DUPLICATE of bug 62395

Status

()

Firefox
Build Config
VERIFIED DUPLICATE of bug 62395
15 years ago
14 years ago

People

(Reporter: Julien Regniaud, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I used these properties in javascript from a basic HTML page:
screen.availWidth and screen.availHeight

When I launch Firebird and I "alert" these properties, it displays the correct 
values. But if I change the screen resolution from windows and I refresh this 
page, Firebird still alert the old values. I have to close and start again 
Firebird to have the updated values.

Reproducible: Always
Steps to Reproduce:
1. Create a HTML page with the following script:
              alert(screen.availWidth)
2. Launch Firebird and check the alert
3. Change the screen resolution from windows
4. Refresh the page and check the alert
5. Re-start Firebird and check again the values

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 62395 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.