wrong autoscroll icon when sidebar open

RESOLVED FIXED

Status

()

Firefox
General
--
trivial
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Francesco Figari, Assigned: Blake Ross)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

If the browser window is wide enough to show a page but the open sidebar robs
some space, firebird still shows the up-down autoscoll icon even if it's
possible to scroll left-right. Looks like the choice of the icon depends on the
window width instead that on (window width - sidebar width)

Reproducible: Always
Steps to Reproduce:
1.Open a wide page
2.open the sidebar
3.use middle button to activate autoscroll

Actual Results:  
I've got vert. and horiz. scroll with the vertical only scroll icon


Expected Results:  
show the cursor that usually appears when the page is too wide

Comment 1

14 years ago
I also see this on Win 2000 on a recent nightly.

However, this bug is probably a dupe of bug 216035
(Reporter)

Comment 2

14 years ago
> However, this bug is probably a dupe of bug 216035

216035 happens if you shrink the window less that the width of the vertical
scrollbar, 'cause probably the page width doesn't change when the scrollbar
appears. In this one the horizontal space for the page effectively changes, but
the sidebar space is... forgotten ?
(Reporter)

Comment 3

14 years ago
just notice it happens also with "weird" pages not tall but very wide,
but directions are swapped in this case.
This is an example: http://sh1ft.org/shutterbug/archives/000225.html

Comment 4

14 years ago
It seems like the icon only gets updated to the 4-way icon if the new scrollbar
is the result of a window size change rather than a viewport size change. I can
confirm this bug with 20040425 Firefox on winXP
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Blocks: 212273
I believe this will be fixed with my patch in bug 296080 (I have tested it on
this bug).
Depends on: 296080
This should be fixed now. Please check with tomorrow's trunk build.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.