Closed Bug 232892 Opened 21 years ago Closed 21 years ago

imap folders which get new mail filtered nto them by client-side filters not getting counts updated or green arrow

Categories

(MailNews Core :: Networking: IMAP, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

(Keywords: regression)

Attachments

(1 file, 3 obsolete files)

Imap folders which get new mail filtered into them by client-side filters are
not getting counts updated or green arrow on the folder, until the folder is
selected in the UI. This is a regression from some code that attempted to fix
counts when the server reports a different unread count than what we think we
have in the folder.
Attached patch prop (obsolete) — Splinter Review
I think the sync Counts code is causing this problem...
actually, that can't be the problem...since that's only called when you click on
the folder.
Attachment #140464 - Attachment is obsolete: true
My current thinking is that this has to do with filters that move messages to
the trash - the code attempts to mark those messages read in the trash, but it
doesn't work. However, it does prevent us from updating the unread msg count on
the trash because locally we think the msg is read. I can either try to fix it
so the messages are marked read in the trash (by marking them read in the inbox
before the move happens), or just remove the code that marks the msg read locally.
Status: NEW → ASSIGNED
OK, the trash problem is a real problem, but the much more general problem is
that we're marking the source messages read when messages are moved/deleted, and
in some situations, we notice that the messages have been marked seen before we
update the pending counts in the target folder, and think that the msg is /SEEN
in the dest folder as well.
Attached patch proposed fix (obsolete) — Splinter Review
count unread messages before we do the move/copy, and use that count when done.
Also, for doing fcc to imap folder, set total count to 1, so sent folder count
will increment correctly.
better fix - don't increment total count if we're a draft or template.
Attachment #140574 - Attachment is obsolete: true
Attachment #140576 - Flags: superreview?(mscott)
I removed the mark read for filtering to trash because it wasn't working - the
message was ending up unread in the trash.
Attachment #140576 - Flags: superreview?(mscott) → superreview+
Blocks: 230700
it turned out the previous patch didn't handle the cross server case correctly.
This one does, and cleans up some unused code.
Attachment #140576 - Attachment is obsolete: true
Attachment #140616 - Flags: superreview?(mscott)
Attachment #140616 - Flags: superreview?(mscott) → superreview+
fixed on trunk and m4 branch.
marking fixed.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: