Microsoft Word documents incorrectly encoded

RESOLVED DUPLICATE of bug 236239

Status

--
major
RESOLVED DUPLICATE of bug 236239
15 years ago
14 years ago

People

(Reporter: mark.bugzilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: 

Microsoft Word documents sent as attachments from Thunderbird 0.4 on a Windows
98 machine cannot be read by the intended recipient as the attachment does not
appear.

Viewing the source of the received message reveals that the document is sent but
it seems to be incorrectly encoded as "Content-Type: multipart/appledouble;"

The Word documents used to find this bug were created using Word 2000 on the
Windows 98 machine. The recipient was using Thunderbird 0.4 on a Windows 2000
machine.

This bug is similar to 232917, however that was only reported for OS X. The same
problem occurs under Windows 98 (but not Windows 2000)


Reproducible: Always
Steps to Reproduce:
1. Compose a new email by pressing the "Write" button
2. Add recipient's address to "To" field and add a subject line
3. Press the "Attach" button and select a Microsoft Word document to attach
4. Once the document is attached, send the email by pressing "Send"


Actual Results:  
The recipient received the sent email and the body of the email appeared
correctly but the attached Word document was not displayed. By opening the email
and typing "Ctrl-U" to view the mail source the document was found to be encoded
as Content-Type: multipart/appledouble

Expected Results:  
The Word attachment should have appeared in the attachments box when the email
was opened.

Comment 1

14 years ago
Duping to a bug with a lot of information about the appledouble problem.

*** This bug has been marked as a duplicate of 236239 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.