Closed Bug 232928 Opened 21 years ago Closed 21 years ago

"DOM inspector" in sidebar is not localizable

Categories

(Other Applications :: DOM Inspector, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.7beta

People

(Reporter: shinichi.hanaki, Assigned: cnst+bmo)

Details

(Keywords: l12y)

Attachments

(1 file, 1 obsolete file)

User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; ja-JP; rv:1.4) Gecko/20040112

"DOM inspector" in sidebar is not i18n'ed although
it is i18n'ed in other areas(preference dialog, the title of DOM inspector
window etc.) 

Reproducible: Always
Steps to Reproduce:
1.Install DOM sidebar 
2.Show sidebar and see "DOM inspector" section
3.

Actual Results:  
"DOM inspector" is displayed in English.

Expected Results:  
It should be localized like "DOM inspector" in the preference dialog.

It seems to be hardcoded at the following file.
extensions/inspector/resources/content/prefs/pref-sidebar.js
Assignee: smontagu → dom-inspector
Component: Internationalization → DOM Inspector
QA Contact: amyy → timeless
Keywords: l12y
Summary: "DOM inspector" in sidebar is not internationalized → "DOM inspector" in sidebar is not localizable
Attached patch Patch (obsolete) — Splinter Review
This is suggested fix.
- Add one new message in invpector.properties
- Use it as sidebar title of DOM inspector in pref-sidebar.js.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #140575 - Flags: superreview?(blizzard)
Attachment #140575 - Flags: review?(jshin)
Status: NEW → ASSIGNED
Flags: blocking1.7b?
Target Milestone: --- → mozilla1.7beta
Assignee: dom-inspector → cnst.bmo
Status: ASSIGNED → NEW
Comment on attachment 140575 [details] [diff] [review]
Patch

jshin is not a peer of inspector
Attachment #140575 - Flags: review?(jshin) → review?(caillon)
Comment on attachment 140575 [details] [diff] [review]
Patch

"DOM Inspector" is the name of the application.  Why should this be localizable
at all?

Hint: "everything else does it" is not a good reason.  I would argue that the
places which currently let you localize it shouldn't...

If there is a good reason to do this though, I'd like to hear it.
(In reply to comment #3)
> (From update of attachment 140575 [details] [diff] [review])
> "DOM Inspector" is the name of the application.  Why should this be localizable
> at all?
> 
> Hint: "everything else does it" is not a good reason.  I would argue that the
> places which currently let you localize it shouldn't...
> 
> If there is a good reason to do this though, I'd like to hear it.

Are you trying to say that localisers should not localise names, i.e. they
should leave Mail & Newsgroups, Composer, IRC Chat? That makes no sense!
Inspector is a common noun, and there should be a way to translate it! 
Status: NEW → ASSIGNED
I'm saying that "DOM Inspector" is the name of an application.  Just like
"Christopher Aillon" is the name of a person.  Just like the browser is named
"Mozilla".  There is no translation.  Just because a name contains "common"
words doesn't mean you can translate it.

For example, "Windows" is a common word in the english language, but when people
refer to that OS in other languages, it is still called "Windows".
(In reply to comment #5)
> I'm saying that "DOM Inspector" is the name of an application.  Just like
> "Christopher Aillon" is the name of a person.  Just like the browser is named
> "Mozilla".  There is no translation.  Just because a name contains "common"
> words doesn't mean you can translate it.
> 
> For example, "Windows" is a common word in the english language, but when people
> refer to that OS in other languages, it is still called "Windows".

My name is written in Cyrillic letters in my birth certificate. Nevertheless, I
am forced to translate it into English, while I am in an English-speaking
community. It would be crude of me to try to supply you with my Cyrillic name...
Does Bugzilla support character sets? Maybe I should try? :-) The same is about
your name --- should you be mentioned in a Russian news-paper or online portal,
your name will be written in Cyrillic. And Russian is not the only language that
does not use Latin. 

Now really, I think it is up to the localisers to do the translation. Do not try
to force people to use one's English names. Besides, "DOM Inspector" string is
already localised in inspector.dtd. 
>> For example, "Windows" is a common word in the english language, 
>> but when people refer to that OS in other languages, it is still 
>> called "Windows"

  I agree with Constantine. 'Windows' is transliterated/transcribed into '윈도우
즈' in the Korean script. Needless to say, the number of people who can
understand a foreign script is smaller than the number of people who can
understand  their native script. Therefore, even proper names have to be
'localized'.  

>Does Bugzilla support character sets? 

  Currently, it's 'neutral' and that has to be changed (no need to file a bug.
there's a bug and we want to make a transition to UTF-8, but it's not so trivial
because there are tons of bugs with comments in various encodings).

> Maybe I should try? :-)

  You can include Cyrillic letters or any characters in Unicode  in your
bugzilla comment. Just make sure to set 'View | Character Coding' to 'UTF-8'
before adding a comment with non-ASCII characters. Using UTF-8, you'll make the
transition (mentioned above) easier.
Comment on attachment 140575 [details] [diff] [review]
Patch

Ok, thank you for the clarifications.  I'm ok with this now but still, I wish
to see one change before this is checked into the tree.

>Index: inspector.properties
>===================================================================
>RCS file: /export/src/cvs/mozilla1.4/mozilla/extensions/inspector/resources/locale/en-US/inspector.properties,v
>retrieving revision 1.1.1.1
>diff -u -r1.1.1.1 inspector.properties
>--- inspector.properties	2003/07/03 07:06:23	1.1.1.1
>+++ inspector.properties	2004/02/03 11:01:26
>@@ -66,3 +66,5 @@
> 10 = Document Type
> 11 = Document Fragment
> 12 = Notation
>+
>+sidebar.title = DOM Inspector

Please put sidebar.title up with the other things above the DOM node types
(underneath findNodesDocumentEnd.title would work).  There is no need for the
segregation or isolation of this one string.

r=caillon with the above modification.
Attachment #140575 - Flags: review?(caillon) → review+
Attached patch Cleaned-up patchSplinter Review
As caillon suggests, move the string along to other strings.
Attachment #140575 - Attachment is obsolete: true
Attachment #140575 - Flags: superreview?(blizzard) → superreview+
checked in
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Flags: blocking1.7b?
Product: Core → Other Applications
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: