− should render as –, not a hyphen, if no special minus glyph is available

RESOLVED WONTFIX

Status

()

Core
Layout: Text
RESOLVED WONTFIX
15 years ago
13 years ago

People

(Reporter: stevenj, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113

On systems like the MacOS, where there is no special glyph for the minus sign,
− renders as a hyphen (-).  An en dash (–) would be a much closer
fit, and I seem to recall it being the one recommended in e.g. Mac typography
guides.  A hyphen, on the other hand, is too short in most fonts.

This is something I first noticed in math pages on Wikipedia (e.g.
http://en.wikipedia.org/wiki/Quaternion) where people were using −.

Reproducible: Always
Steps to Reproduce:
create a web page with − for minus signs
Actual Results:  
got a hyphen glyph on MacOS

Expected Results:  
expected a longer dash, e.g. an –

Comment 1

15 years ago
This happens due the way the transliteration fallback works. Currently, glyphs
without fonts cannot be translitaterate to yet another Unicode point. They can
only be transliterated to ASCII -- which is certain to have a font.
 
Consequently, the − is transliterated to something close in the ASCII set.
And '-' is the closest.

It will be much work to redesign the transliteration system (with ramifications
into platform codes to further deal with missing glyphs even after the
transliteration). Suggesting wontfix, knowing that transliteration is a
desperate fallback, and people can install fonts, and this saves from further
bloat/complexity to Gecko in the belief that it should be responsible for
every/anything.

Comment 2

15 years ago
I agree with rbs. 
*** Bug 236160 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

13 years ago
Created attachment 197643 [details]
short .html file showing hyphen, minus, and ndash glyphs
(Reporter)

Comment 6

13 years ago
This still occurs in Firefox 1.0.7, but I guess this is expected from the
"wontfix" tag.
You need to log in before you can comment on or make changes to this bug.