Add "Filter" button to the "Cookie Manager|Cookie Sites" tab

RESOLVED DUPLICATE of bug 141906

Status

()

Core
Networking: Cookies
RESOLVED DUPLICATE of bug 141906
14 years ago
14 years ago

People

(Reporter: ow, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

On the Tools|Cookie Manager|Manage Stored Cookies|Cookie Sites tab:
Add "Filter" button (or replace Block/Allow buttons (they are useless IMHO) with
Filter button).


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Not sure of the component but certainly not DOM Abstract Schemas.
Assignee: general → guifeatures
Component: DOM: Abstract Schemas → XP Apps: GUI Features

Updated

14 years ago
Assignee: guifeatures → darin
Component: XP Apps: GUI Features → Cookies
QA Contact: ian → cookieqa
(Reporter)

Comment 2

14 years ago
Suppose, several servers in the domain are setting cookies and cookies from all
are set to be blocked. How do I unblock cookies from the whole domain, e.g.
www.yahoo.com
mail.yahoo.com
signon.yahoo.com

Currently there's no way to do this except for going through the list of blocked
servers and setting them one by one. This is a hell of an exercise if one has a
lot of servers blocked.
(Reporter)

Comment 3

14 years ago
version 1.7.beta
adding UI to solve an implementation detail isn't the answer here.  better
sorting based on domain will help more here (see bug 142179, which may get
further evolved/nested, I haven't looked at it seriously yet)

this is mostly a dupe of bug 141906, other than the implementation part of the
request, and I don't think that this implementation is especially useful/solid
in the current UI, duping to that bug, which uses more of a "find as you type"
concept which works better without visual clutter.  In combination with the
better sorting that makes space-consuming elements unnecessary.


*** This bug has been marked as a duplicate of 141906 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

14 years ago
> better sorting based on domain will help more here 

I think it's wrong. I don't want to go through all posible domain combinations like:
forumns.someco.net
www.someco.com
whatever1.someco.org
whatever1.someco.tv and etc.

Filtering on "someco" would give all the records in question when sorting does
not. After strugling for an hour trying to find all blocked servers (still
couldn't find all) I have to say that cookie management really really sucks.
 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

14 years ago
mconnor has provided you with references to two already-existing bugs, either
one of which would solve your problem. bug 142179, sorting from the top-level
domain down, would result in grouping *.someco.com together visually; i don't
think it's desirable to have .org, .com, .net etc grouped together, since sites
never spread themselves across different tld's in practice.

bug 141906 already describes your request closely enough for this bug to be a
duplicate. please direct any further suggestions or comments to that bug, and
refrain from gainsaying the decisions of those responsible for the cookiemanager
in an insulting way.

you know, your bugzilla name is quite fitting in this context... you sure can be
a pain in the ass.

*** This bug has been marked as a duplicate of 141906 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.