'onClose' popups circumvent the popupblocker when frames are used

RESOLVED WORKSFORME

Status

()

Core
Disability Access APIs
--
major
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Nate Fox, Assigned: Blake Ross)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031015 Firebird/0.7 (aebrahim)

When using standard frames, a javascript 'on exit' popup will appear. This
completely circumvents the popup blocking in Firebird.

Reproducible: Always
Steps to Reproduce:
1. Load the HTML/Javascript pages in the frameset (testcase included)
2. Close the *tab* (closing the browser does not invoke this)

Actual Results:  
A popup window showed up.

Expected Results:  
Popup window should not show up when exiting the web page.

testcase is a set of 3 pages. index.html is the frameset page, which calls
main.html as the 'main' frame and pop.html as the hidden frame. pop.html has the
onClose javascript.
(Reporter)

Comment 1

15 years ago
Created attachment 140578 [details]
Index page w/ the frames
(Reporter)

Comment 2

15 years ago
Created attachment 140579 [details]
Main html frame in frameset
(Reporter)

Comment 3

15 years ago
Created attachment 140580 [details]
Hidden page in frames containing 'onclose' javascript

Comment 4

15 years ago
Is this still a problem after the checkins for bug 197919?

Comment 5

15 years ago
(In reply to comment #4)
> Is this still a problem after the checkins for bug 197919?

Yes, it is.

Comment 6

14 years ago
This seems to be okay now in FF (20040530), but occurs in Moz. 1.7rc2 and 1.8a1

Comment 7

14 years ago
Confirmed: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040621 Firefox/0.9.0+

I can reproduce this using the testcase, on the branch.  However, on the current
trunk: ...rv:1.8a2) Gecko/20040622 Firefox/0.8.0+ it will not popup.

So something that was checked into the trunk but not the branch fixes this bug.

Comment 8

14 years ago
(In reference to comment #6 and #7)
#6
> This seems to be okay now in FF (20040530), but occurs in Moz. 1.7rc2 and 1.8a1
#7
>I can reproduce this using the testcase, on the branch.  However, on the current
>trunk: ...rv:1.8a2) Gecko/20040622 Firefox/0.8.0+ it will not popup

If this bug cannot be reproduced in Firefox but in Moz, I will cange the product.
Component: General → Accessibility APIs
Product: Firefox → Browser
Version: unspecified → Other Branch
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 10

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.