Cookie Manager: Sites removed with 'delete' key not disallowed from future cookies

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: twb0, Assigned: darin.moz)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040202

In Cookie Manager, if you remove a cookie with the "Remove Cookie" or "Remove
All Cookies" button and have the "Don't allow sites that set removed cookies to
set future cookies" box checked, they will be added to the "Cookie Sites" tab
with a status of "site cannot set cookies".

However, if you use the "Delete" key to remove a cookie under the same
conditions it is *not* added to the "Cookie Sites" tab, but rather is simply
deleted.

Reproducible: Always
Steps to Reproduce:
1. Make sure "Don't allow sites that set removed cookies to set future cookies"
box is checked.
2. Highlight a cookie in "Cookie Manager".
3. Hit 'Delete' key to remove cookie.
Actual Results:  
Cookie is deleted *without* being added to the "Cookie Sites" tab with a status
of "site cannot set cookies".

Expected Results:  
'Delete' key should have exactly the same effect as clicking "Remove Cookie" button.
Works for me.
Did you close the cookie manager before looking at the sites tab? I somehow
remember a bug about the sites tab not being updated.
(Reporter)

Comment 2

15 years ago
Good call--after further testing (i.e. close cookie manager and reopen) I see
that all the deleted cookes are indeed listed.  That makes my complaint more
relevant to the comments in existing Bug 220915 (cookie site list was suddenly
empty; cookie list was not affected).

*** This bug has been marked as a duplicate of 220915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Thomas,

If I'm reading this bug correctly, it is not the same problem as what is
described in 220915, but have had some problems where they might be releated.

The delete key (vs. the buttons) are pretty much a separate, testable feature,
so I think this is best resolved WFM, which you can do as a reporter.

Let me know if I've got this wrong.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

15 years ago
Agreed--the 'delete' key does indeed work, it's success was just masked by the
existence of the other bug.  Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
V.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.