deleted mail from pop folders is not deleted from the hard disk

VERIFIED INVALID

Status

MailNews Core
Database
VERIFIED INVALID
14 years ago
10 years ago

People

(Reporter: Dan Reynolds, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

In cleaning up the hard-disk space used by my account, I went through my mail
saved mail folders deleting many large files.  However, when checking the
resulting disk usage, I found that the email storage files in my
.mozilla/.../Mail/<pop_server> directory still had the deleted emails.  Most
notably, messages that had been downloaded to my inbox from the pop server and
subsequently deleted or moved to other folders were still in the mail file.

I believe that the mail program should do a better job about hogging disk space,
especially since it currently retains multiple copies of large attachments that
have subsequently been deleted.

Reproducible: Always
Steps to Reproduce:
1. download mail from a pop server
2. save a message to some sub-folder
3. [maybe] restart mozilla
3. delete the message from the sub-folder
4. [maybe] restart mozilla
Actual Results:  
I looked in the correspond mail files for both the inbox and the sub-folder, and
saw that the saved/deleted message was still in both files.


Expected Results:  
delete the "deleted" message from the hard disk, both when messages are moved
from the inbox, and when they are deleted from various mail folders.

Comment 1

14 years ago
See bug 128744
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> See bug 128744

Sure, this is similar to bug 128744, in that things aren't getting deleted, but
it has to do with messages themselves and not whole accounts.
(Assignee)

Comment 3

14 years ago
this is the way our mailbox format works. To remove the deleted message, you
must compact the folder - you can either file | compact all folders, or folder
context menu | compact this folder, or you can set your offline and diskspace
prefs setting to automatically compact folders when it will save XX KB.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
v invalid
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

14 years ago
Thanks David, I was previously unaware of the 'compact folders' command.  All
that I wanted was the ability to free the disk space without going through the
mail files by hand.

Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.