Mozilla "unexpectedly quit" and now stuck complaining about being in offline mode

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Backend
--
critical
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Alan Batie, Assigned: Bienvenu)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.6/mozilla-mac-MachO-1.6.dmg.gz

I was checking my daily sites and had just gotten to the IMDB daily news (though
I don't think it's related to that specific page), when Mozilla "unexpectedly
quit".  When I tried to restart it, it gives me the dialogue about "This
document cannot be displayed while offline", and I can't open any browser
windows.  The "Work Offline" is not checked.  I rebooted the Mac, to no avail. 
I didn't see any log files in the Applications/Mozilla Folder directory.  Win2K
Mozilla 1.6 views the imdb page fine.

Reproducible: Didn't try
Steps to Reproduce:
1.Can't get mozilla restarted to try to reproduce it.
2.
3.
(Reporter)

Comment 1

14 years ago
I forgot to add that this sounds similar to bug 193308, except restarting
Mozilla does *NOT* fix it...

Comment 2

14 years ago
Please check the following preferences: 

"offline.startup_state" 

0 = remember last state, 1 = ask me, 2 == online, 3 == offline

"network.online" 

true/false
Component: Browser-General → Offline
Product: Browser → MailNews

Updated

14 years ago
Assignee: general → bienvenu
QA Contact: general → grylchan
(Reporter)

Comment 3

14 years ago
There was no "offline.startup_state" in prefs.js, but network.online was set to
false.  I changed it to "true" and that fixed the problem.  Thanks!  I would say
mark Resolved, except there's still the question of why the browser crashed, and
how it managed to change the online state when it did...
(Assignee)

Comment 4

14 years ago
I don't know why that would happen, but I've seen something like that myself.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
Created attachment 140698 [details]
Updated version of offlineStartup.js
Product: Browser → Seamonkey

Comment 6

9 years ago
still see this?
QA Contact: grylchan → mailnews-backend
(In reply to comment #6)
> still see this?

This is a MacOsX bug, I don't remember ever seeing the same on Linux.

Updated

9 years ago
Whiteboard: closeme 2009-02-01
(Reporter)

Comment 8

9 years ago
I haven't been using seamonkey for quite a file, switched back to firefox; I probably should try it again since firefox 3 refuses to honor the "open new pages in a new window" setting.  but that's another issue...  I would consider it closed
Resolving WFM according to comment #8. REOPEN if seen in a current build (and paste its user-agent string, as seen after "Build ID" at the bottom of the about: page).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme 2009-02-01
You need to log in before you can comment on or make changes to this bug.