RoboHelp generated WebHelp - Javascript loops

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: William Hofmeyr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: bugday0420, URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040202

When displaying pages apparently generated by RoboHelp, Mozilla goes 
into an infinite loop.

Pressing "Stop" does not help because after a moment Mozilla 
(Javascript) retries - one must switch to another page to .

There *is* an error in the Javascript but I don't know if this is causing the 
observed behaviour.
   Error: document.body has no properties
   Source File: http://www.acts.co.za/ntl_veld_forest/whmozemu.js
   Line: 50

   Error: setting a property that has only a getter
   Source File: http://www.acts.co.za/ntl_veld_forest/whmozemu.js
   Line: 52

I have been able to look at the site, so eventually (after about 6MB 
has been transferred) the page is displayed. (Once quite quickly
after a cache purge - clutching at straws).

While typing this description the site listed below has eventually 
displayed so the Javascript errors are not fatal but may cause the 
reloading.

Another example URL is: http://www.acts.co.za/ntl_veld_forest/veld_and_forest.htm

This not the same as bug 208642, but it does seem as if RoboHelp 
generates IE specific code.

Reproducible: Always
Steps to Reproduce:
1. go to http://winamp.com/support/help/50/Winamp5.htm
2.
3.

Actual Results:  
The page was repeatedly updated before rendering had cpmpleted.

Expected Results:  
Displayed the page (frames).

Comment 1

13 years ago
*** Bug 252965 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

13 years ago
I see the bug too, but this may belong in tech. evang.

Comment 3

13 years ago
WFM (I don't see this effect)

Loads and renders in an instant.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
MultiZilla/1.6.3.3a
Product: Browser → Seamonkey

Comment 4

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 5

8 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.1.10pre) Gecko/20100419 Lightning/1.0b2pre SeaMonkey/2.0.4pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Whiteboard: bugday0420
You need to log in before you can comment on or make changes to this bug.