Last Comment Bug 233146 - option to let javascript console to stay on top always
: option to let javascript console to stay on top always
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
-- enhancement (vote)
: ---
Assigned To: Blake Ross
: Mike Connor [:mconnor]
:
Mentors:
: 351059 484922 541685 778515 (view as bug list)
Depends on:
Blocks: 490886
  Show dependency treegraph
 
Reported: 2004-02-05 04:18 PST by aceman3000
Modified: 2013-04-19 13:00 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image aceman3000 2004-02-05 04:18:22 PST
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

It would be nice if there´s an option to let the javascript console to stay
always on top. good thing for web developers like me.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 User image Mike Connor [:mconnor] 2004-02-05 08:36:14 PST
this might be useful as an extension, but this isn't a feature a normal user
would ever want.
Comment 2 User image Simon Bünzli 2006-09-16 05:54:38 PDT
*** Bug 351059 has been marked as a duplicate of this bug. ***
Comment 3 User image Ria Klaassen (not reading all bugmail) 2009-03-24 08:21:11 PDT
*** Bug 484922 has been marked as a duplicate of this bug. ***
Comment 4 User image Jason Cipriani 2009-03-24 10:18:29 PDT
The code evaluator in the Error Console isn't a feature that a normal user would ever want, either.

Please reopen this, this is not a valid reason for wontfix, and the current behavior is extremely annoying.
Comment 5 User image Mike Connor [:mconnor] 2009-03-24 10:24:05 PDT
It's entirely reasonable.  If you want features useful for debugging, you should install Firebug or any of the other developer-oriented extensions.  Firebug puts the error console in the same window in a panel, it's a much better solution overall.
Comment 6 User image Jason Cipriani 2009-03-24 10:27:51 PDT
s/reasonable/inconsistent

But there are extensions that solve the problem, so not an issue. As of the time of this post, there are at least two extensions that add the feature:

  - Bottom Error Console 
    https://addons.mozilla.org/en-US/firefox/addon/9223

  - Console2 
    https://addons.mozilla.org/en-US/firefox/addon/1815
Comment 7 User image Philip Chee 2010-01-23 09:57:01 PST
*** Bug 541685 has been marked as a duplicate of this bug. ***
Comment 8 User image Colby Russell :crussell (no longer Mozilla-ing) 2013-04-19 13:00:41 PDT
*** Bug 778515 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.